Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455178 - NetworkManager fails to update via yum update
Summary: NetworkManager fails to update via yum update
Keywords:
Status: CLOSED DUPLICATE of bug 451519
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 8
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-13 14:30 UTC by James Crawford
Modified: 2008-07-24 22:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-24 22:38:49 UTC


Attachments (Terms of Use)

Description James Crawford 2008-07-13 14:30:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.15) Gecko/20080702 Fedora/2.0.0.15-1.fc8 Firefox/2.0.0.15

Description of problem:
Running yum update returna the following.

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Updating:
 NetworkManager          x86_64     1:0.7.0-0.6.9.svn3675.fc8  updates           787 k
 NetworkManager-glib     x86_64     1:0.7.0-0.6.9.svn3675.fc8  updates           131 k
 NetworkManager-glib     i386       1:0.7.0-0.6.9.svn3675.fc8  updates           130 k
 NetworkManager-gnome    x86_64     1:0.7.0-0.6.9.svn3675.fc8  updates           336 k
 NetworkManager-openvpn  x86_64     1:0.7.0-10.svn3632.fc8  updates           136 k
 NetworkManager-vpnc     x86_64     1:0.7.0-0.7.7.svn3627.fc8  updates           110 k
Installing for dependencies:
 ppp                     x86_64     2.4.4-2          fedora            387 k

Transaction Summary
=============================================================================
Install      1 Package(s)         
Update       6 Package(s)         
Remove       0 Package(s)         

Total download size: 2.0 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
Package NetworkManager conflicts with NetworkManager-vpnc < 1:0.7.0-0.7.7.svn3549.
Package NetworkManager conflicts with NetworkManager-openvpn < 1:0.7.0-9.svn3549.
Package NetworkManager needs NetworkManager-glib = 1:0.7.0-0.6.7.svn3370.fc8, this is not available.
Package NetworkManager needs NetworkManager-glib = 1:0.7.0-0.6.7.svn3370.fc8, this is not available.
Complete!


Version-Release number of selected component (if applicable):
NetworkManager          x86_64     1:0.7.0-0.6.9.svn3675.fc8  updates 

How reproducible:
Always


Steps to Reproduce:
1.Fedora 8 X86-64 with current updates 
2.as root run yum update
3

Actual Results:
See Discription

Expected Results:
Should have completed the update, problem appears to be in the packaging of NetworkManager.

Additional info:

Comment 1 Jeff Bastian 2008-07-13 15:30:05 UTC
I managed to upgrade to svn3675 by removing all i386 packages first.  Actually,
I removed all the NetworkManager* packages, then installed the previous updates
with 'rpm', and then 'yum -y update' successfully updated everything.  Now I
only have x86_64 packages installed.

Comment 2 Brendan LeFebvre 2008-07-14 15:08:08 UTC
Confirming Jeff's experience, though I only went so far as deleting the i386
packages. So two commands did it:

# yum erase NetworkManager*386
# yum update



Comment 3 James Crawford 2008-07-16 00:27:11 UTC
I got it fixed with a little overkill 

yum erase NetworkManager*
yum install NetworkManager*x86_64


I now only have x86_64 packages installes.

Thks.

Comment 4 Dan Williams 2008-07-18 17:41:23 UTC

*** This bug has been marked as a duplicate of 451519 ***

Comment 5 Jeff Bastian 2008-07-18 17:44:26 UTC
This bug is for Fedora 8, not 9, so this is a clone of 451519, not a duplicate.
 Re-opening.

Comment 6 Dan Williams 2008-07-24 22:38:49 UTC

*** This bug has been marked as a duplicate of 451519 ***


Note You need to log in before you can comment on or make changes to this bug.