Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455177 - Wine-1.1.1 doesn't compile on gcc 4.3.0
Summary: Wine-1.1.1 doesn't compile on gcc 4.3.0
Keywords:
Status: CLOSED DUPLICATE of bug 440139
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc
Version: 9
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-13 13:50 UTC by ruslan
Modified: 2008-07-14 14:18 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-14 14:18:29 UTC


Attachments (Terms of Use)

Description ruslan 2008-07-13 13:50:19 UTC
$ cd wine-1.1.1
$ ./configure --with-x
............................
config.status: executing dlls/user32/resources commands
config.status: executing dlls/wineps.drv/data commands
config.status: executing include/wine commands

configure: libsane development files not found, scanners won't be supported.
configure: libgphoto2 development files not found, digital cameras won't be
supported.
configure: liblcms development files not found, Color Management won't be supported.
configure: libcapi20 development files not found, ISDN won't be supported.
configure: libcups development files not found, CUPS won't be supported.

configure: Finished.  Do 'make depend && make' to compile Wine.
$ make depend && make
.......................
gcc -c -I. -I. -I../../../include -I../../../include   -D_REENTRANT -fPIC -Wall
-pipe -fno-strict-aliasing -Wdeclaration-after-statement -Wwrite-strings
-Wtype-limits -Wpointer-arith  -g -O2  -o input.o input.c
gcc -c -I. -I. -I../../../include -I../../../include   -D_REENTRANT -fPIC -Wall
-pipe -fno-strict-aliasing -Wdeclaration-after-statement -Wwrite-strings
-Wtype-limits -Wpointer-arith  -g -O2  -o listbox.o listbox.c
gcc -c -I. -I. -I../../../include -I../../../include   -D_REENTRANT -fPIC -Wall
-pipe -fno-strict-aliasing -Wdeclaration-after-statement -Wwrite-strings
-Wtype-limits -Wpointer-arith  -g -O2  -o menu.o menu.c
{standard input}: Assembler messages:
{standard input}:7412: Warning: end of file not at end of a line; newline inserted
{standard input}:7745: Error: unknown pseudo-op: `.l'
gcc: Внутренняя ошибка: Ошибка сегментирования (программа cc1)
Пожалуйста, пришлите полный отчёт об ошибке.
См. инструкции на <http://bugzilla.redhat.com/bugzilla>.
make[2]: *** [menu.o] Ошибка 1
make[2]: Leaving directory `/home/src/wine-1.1.1/dlls/user32/tests'
make[1]: *** [user32/tests] Ошибка 2
make[1]: Leaving directory `/home/src/wine-1.1.1/dlls'
make: *** [dlls] Ошибка 2

$ gcc --version
gcc (GCC) 4.3.0 20080428 (Red Hat 4.3.0-8)
$ uname -a
Linux ruslan.localhost.localdomain 2.6.25.6-55.fc9.i686 #1 SMP Tue Jun 10
16:27:49 EDT 2008 i686 i686 i386 GNU/Linux

Comment 1 Jakub Jelinek 2008-07-14 14:18:29 UTC

*** This bug has been marked as a duplicate of 440139 ***


Note You need to log in before you can comment on or make changes to this bug.