Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455163 - the file 'mptopdf.pl' is not found
Summary: the file 'mptopdf.pl' is not found
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: texlive
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-13 10:14 UTC by M.R. Beauchamp
Modified: 2013-07-02 23:30 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-11-21 10:59:10 UTC


Attachments (Terms of Use)

Description M.R. Beauchamp 2008-07-13 10:14:21 UTC
Description of problem:

Updated box from f8 to f9, started mptopdf as normal, but got an error

[metapoststuff]$ mptopdf examples.1
the file 'mptopdf.pl' is not found

Version-Release number of selected component (if applicable):


[metapoststuff]$ rpm -qif /usr/bin/mptopdf
Name        : texlive-context              Relocations: (not relocatable)
Version     : 2007                              Vendor: Fedora Project
Release     : 30.fc9                        Build Date: Mon 05 May 2008 10:53:15
PM CEST
Install Date: Sun 13 Jul 2008 09:48:23 AM CEST      Build Host:
xenbuilder4.fedora.phx.redhat.com
Group       : Applications/Publishing       Source RPM: texlive-2007-30.fc9.src.rpm
Size        : 105668                           License: GPLv2 and BSD and Public
Domain and LGPLv2+ and GPLv2+ and LPPL
Signature   : DSA/SHA1, Tue 06 May 2008 04:31:45 AM CEST, Key ID b44269d04f2a6fd2
Packager    : Fedora Project
URL         : http://tug.org/texlive/
Summary     : ConTeXt is a document preparation system based on TeX
Description :
ConTeXt is a document preparation system based on TeX.



How reproducible:

see above


Expected results:

mptopdf just starts as in f8

Comment 1 Vasile Gaburici 2008-08-08 15:51:22 UTC
The problem is that texlive-context does not currently require texlive-texmf-context, although it should do. Oddly enough texlive-context does require texlive-texmf-errata-context.

Other ConTeXt tools are broken too because of this, for instance texfont (ConTeXt font installation tool) complains that it cannot fint texfont.pl.

You should increase the severity of this bug.

Comment 2 Jindrich Novy 2008-10-15 10:07:48 UTC
Please test the following update if you have a while:
https://admin.fedoraproject.org/updates/texlive-2007-32.fc9,texlive-texmf-2007-24.fc9

It should finally fix this and couple of other issues :)

Comment 3 Fedora Update System 2008-10-20 20:29:47 UTC
texlive-texmf-2007-24.fc9, texlive-2007-32.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update texlive-texmf texlive'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-8931

Comment 4 Fedora Update System 2008-11-21 10:58:42 UTC
texlive-texmf-2007-24.fc9, texlive-2007-32.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.