Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455150 - Not able to login to WPA networks anymore
Summary: Not able to login to WPA networks anymore
Keywords:
Status: CLOSED DUPLICATE of bug 453827
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 8
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-12 22:33 UTC by Roland Wolters
Modified: 2008-07-14 13:26 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-14 13:26:21 UTC


Attachments (Terms of Use)
Output of /var/log/messages during a failed login attempt. (deleted)
2008-07-12 22:33 UTC, Roland Wolters
no flags Details
Manual wpa_supplicant attempt. (deleted)
2008-07-12 22:35 UTC, Roland Wolters
no flags Details

Description Roland Wolters 2008-07-12 22:33:18 UTC
Description of problem:
Suddenly I'm not able to login to my WPA-networks anymore. I've tested against 
three different routers. A Windows Vista on the same laptop is able to login 
to these routers, so a hardware failure is unlikely.

Version-Release number of selected component (if applicable):
NetworkManager-0.7.0-0.6.9.svn3675.fc8
wpa_supplicant-0.5.10-5.fc8
0c:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN 
Network Connection (rev 61)
kernel 2.6.25.9-40.fc8

How reproducible:
Try to login to a WPA secured network.
  
Actual results:
It doesn't work. I will attach the /var/log/messages output.

Expected results:
It should've worked. It did so until July 11. At July 10, after the updates, 
it also still worked.

Comment 1 Roland Wolters 2008-07-12 22:33:18 UTC
Created attachment 311655 [details]
Output of /var/log/messages during a failed login attempt.

Comment 2 Roland Wolters 2008-07-12 22:35:05 UTC
Created attachment 311656 [details]
Manual wpa_supplicant attempt.

I tried to login via wpa_supplicant alone - this didn't work either, but there
I cannot guarantee that the wpa_supplicant.conf file was created properly
because I wasn't able to test it.

Comment 3 Jeff Bastian 2008-07-13 22:40:28 UTC
Using gnome-keyring-manager, I looked at the WPA-PSK password stored in my
keyring and it's a long random string instead of my pre-shared key.  The last
time I did this it showed my pre-shared key.

Comment 4 Jeff Bastian 2008-07-13 23:41:36 UTC
(In reply to comment #3)
> Using gnome-keyring-manager, I looked at the WPA-PSK password stored in my
> keyring and it's a long random string instead of my pre-shared key.  The last
> time I did this it showed my pre-shared key.

Never mind, apparently my memory is faulty.  I just downgraded NetworkManager,
wpa_supplicant, and the kernel to:
   NetworkManager-0.7.0-0.6.7.svn3370.fc8.i386
   NetworkManager-0.7.0-0.6.7.svn3370.fc8.x86_64
   NetworkManager-glib-0.7.0-0.6.7.svn3370.fc8.i386
   NetworkManager-glib-0.7.0-0.6.7.svn3370.fc8.x86_64
   NetworkManager-gnome-0.7.0-0.6.7.svn3370.fc8.x86_64
   NetworkManager-openvpn-0.7.0-8.svn3302.fc8.x86_64
   NetworkManager-vpnc-0.7.0-0.6.3.svn3109.fc8.i386
   NetworkManager-vpnc-0.7.0-0.6.3.svn3109.fc8.x86_64
   kernel-2.6.25.4-10.fc8.x86_64
   wpa_supplicant-0.5.10-4.fc8.x86_64

and now I can connect to my WPA network again.  But gnome-keyring-manager still
shows a long string of random characters...

The last downgrade I did was the kernel and that's when it started working, so
I'm going to upgrade NetworkManager* and wpa_supplicant and see if it still works.


Comment 5 Jeff Bastian 2008-07-14 00:05:56 UTC
This appears to be a kernel bug.  I removed the i386 packages (see bug 455178,
comment #1), then upgraded to the latest NetworkManager* and wpa_supplicant
packages:
   NetworkManager-0.7.0-0.6.9.svn3675.fc8.x86_64
   NetworkManager-glib-0.7.0-0.6.9.svn3675.fc8.x86_64
   NetworkManager-gnome-0.7.0-0.6.9.svn3675.fc8.x86_64
   NetworkManager-openvpn-0.7.0-10.svn3632.fc8.x86_64
   NetworkManager-vpnc-0.7.0-0.7.7.svn3627.fc8.x86_64
   wpa_supplicant-0.5.10-5.fc8.x86_64

Then I tried both the 2.6.25.4-10.fc8 and the 2.6.25.9-40.fc8 kernels and the
WPA network works fine with 2.6.25.4-10.fc8, but it breaks with 2.6.25.9-40.fc8.

Looking at the changelog for kernel-2.6.25.9-40.fc8, there have been a lot of
wireless updates recently.  Apparently one of the changes broke WPA.


Comment 6 Jeff Bastian 2008-07-14 00:07:02 UTC
Changing component to kernel

Comment 7 Jeff Bastian 2008-07-14 00:20:28 UTC
BTW, I'm on a Lenovo T60 with:

03:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network
Connection (rev 02)


Comment 8 John W. Linville 2008-07-14 13:26:21 UTC

*** This bug has been marked as a duplicate of 453827 ***


Note You need to log in before you can comment on or make changes to this bug.