Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455147 - libgcrypt needs at least version 1.5 of libgpg-error
Summary: libgcrypt needs at least version 1.5 of libgpg-error
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: libgcrypt
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-12 19:54 UTC by Noa Resare
Modified: 2008-07-14 16:01 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-14 16:01:41 UTC


Attachments (Terms of Use)

Description Noa Resare 2008-07-12 19:54:26 UTC
Description of problem:
The symbol gpg_err_code_from_syserror showed up between 1.4 and 1.5 of libgpg-error according to 
the ChangeLog. A small improvement to the libcrypt package would be to add this dependency 
explicitly to the package.

Version-Release number of selected component (if applicable):
1.4.0-3

How reproducible:
always

Steps to Reproduce:
1. try to recompile libgcrypt on for example rhel4
2.
3.
  
Actual results:
compilation fails with missing symbol gpg_err_code_from_syserror

Expected results:


Additional info:

Comment 1 Nalin Dahyabhai 2008-07-14 16:01:41 UTC
Despite the changelog, the function appears to have landed in time for 1.4, as
it's in the F7 package's source tree.  It looks like the requirement on >=1.4 is
correct, so I'm marking this won't-fix.  Please reopen this bug report if I've
missed something.

Thanks!


Note You need to log in before you can comment on or make changes to this bug.