Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455145 - GDM crashes on startup
Summary: GDM crashes on startup
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm
Version: 9
Hardware: All
OS: Linux
low
urgent
Target Milestone: ---
Assignee: jmccann
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-12 19:17 UTC by Espen Stefansen
Modified: 2015-01-14 23:21 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-03-10 21:12:24 UTC


Attachments (Terms of Use)
crash-log for gdm (deleted)
2008-07-12 19:17 UTC, Espen Stefansen
no flags Details

Description Espen Stefansen 2008-07-12 19:17:56 UTC
Description of problem:
After I updated gdm, gdm crashes on startup. The login-screen is shown for a couple of seconds, then 
gdm restarts. The weird thing is that no users is shown on the login-menu in the few glimpses i could see.
In the log, gconf gives lots of errors. 

Version-Release number of selected component (if applicable):
gdm-user-switch-applet-2.22.0-8.fc9.i386
gdm-2.22.0-8.fc9.i386
GConf2-gtk-2.22.0-1.fc9.i386
GConf2-2.22.0-1.fc9.i386
gnome-python2-gconf-2.22.1-2.fc9.i386


How reproducible:
Every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:
gdm restarts itself once the login-menu is shown

Expected results:
Could log in

Additional info:

Comment 1 Espen Stefansen 2008-07-12 19:17:56 UTC
Created attachment 311648 [details]
crash-log for gdm

Comment 2 Espen Stefansen 2008-07-25 18:06:02 UTC
Does anyone know what causes this? Because of this, I can't start in graphical mode. I must start in 
runlevel 3 and use startx.

Comment 3 Christopher Beland 2009-03-10 20:28:50 UTC
I'm not a gdm expert, but it seems likely that there is something about your configuration or hardware in particular that is triggering this crash.

The first thing to do is to apply the latest system updates (e.g. with "yum update") if you haven't already, and see if the problem is fixed.

Normally with crashes a backtrace is necessary for the developers to pin down the cause, but that is more difficult to do with gdm, since it happens before login.  It might be more productive to try resetting the various packages you mentioned to their default configurations, one by one.  If you would like to help find the cause of the problem, the best thing might be to do the following for each RPM, one by one: save the output of rpm -V, remove the RPM, move its configuration files and cached data aside (for later examination), reinstall the RPM, and retest.  If you can find some local state that triggers the crash, that intelligence might be helpful in making the program more robust.

You also have the option of upgrading to Fedora 10, to see if a newer version will be more robust in the face of whatever local state is triggering the crash in Fedora 9.  If you merely wish to be rid of this problem (if you aren't already) and don't care to track down the source, a really fresh install of Fedora 9 or 10 (you may wish to format the partition to ensure that no old state is retained, but you will need to save personal data somewhere else, and reconfigure the system from scratch) will probably fix it (unless it is due to hardware peculiarity, not saved state).

---

Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 4 Espen Stefansen 2009-03-10 21:12:24 UTC
This was fixed in an later update to gdm, so i'm closing this one.


Note You need to log in before you can comment on or make changes to this bug.