Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455130 - can not start ksmserver, ASSERT: "d" in ... kdecore/kernel/kcomponentdata.cpp, line 158
Summary: can not start ksmserver, ASSERT: "d" in ... kdecore/kernel/kcomponentdata.cpp...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kdelibs
Version: rawhide
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: KDE41
TreeView+ depends on / blocked
 
Reported: 2008-07-12 13:42 UTC by Rex Dieter
Modified: 2008-08-29 15:23 UTC (History)
3 users (show)

Fixed In Version: 4.0.98-2.fc10
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-12 22:11:04 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
KDE Software Compilation 170043 None None None Never

Description Rex Dieter 2008-07-12 13:42:42 UTC
Just and fyi, haven't had much chance to look more, but kde-4.0.98 (built for
F-9 here), falls over with many-a-error of the form:

kdeinit4: preparing to launch /usr/libexec/kde4/klauncher
ASSERT: "d" in file
/builddir/build/BUILD/kdelibs-4.0.98/kdecore/kernel/kcomponentdata.cpp, line 158
kdeinit4: (klauncher /usr/libexec/kde4/klauncher) Pipe closed
unexpectedlykdeinit4: Pipe closed unexpectedly: No such file or director

Comment 1 Kevin Kofler 2008-07-12 16:04:50 UTC
Argh, sounds badly broken!

Comment 2 Kevin Kofler 2008-07-12 16:11:03 UTC
The context:
156 KStandardDirs *KComponentData::dirs() const
157 {
158       Q_ASSERT(d);
159       d->lazyInit(*this);
160         
161       return d->dirs;
162 }

The code of KComponentData hasn't changed since September 2007. I think we need 
a backtrace for this assertion failure.

Comment 3 Rex Dieter 2008-07-12 16:21:00 UTC
Confirmed going back to kde-4.0.85 is ok, so seems to be something particular to
4.0.98.  I'm tempted to try rebuilding everything again, to confirm it's just
not a quirk in my own builds (at least until we have any confirmation of folks
seeing this on rawhide too).

Once I confirm that, I'll get to work on getting a backtrace.

Fwiw, the 4.0.98 F-9 builds I'm using here are currently in repos at
http://apt.kde-redhat.org/apt/kde-redhat/mock/fedora-9-i386-kde/
http://apt.kde-redhat.org/apt/kde-redhat/mock/fedora-9-x86_64-kde/

Comment 4 Rex Dieter 2008-07-12 17:35:25 UTC
How most folks will experience this is that login will fail with error:
can not start ksmserver

Comment 5 Rex Dieter 2008-07-13 00:36:24 UTC
I've confirmed that a kdelibs build omitting our nocache and kstandarddirs
patches still exhibits this problem (so I'm hoping that means that those patches
don't contribute to it).

Comment 6 Kevin Kofler 2008-07-13 00:42:19 UTC
Any chance you can get a stack trace for that? It might help figuring out 
what's going wrong.

Comment 7 Kevin Kofler 2008-07-13 00:47:58 UTC
(For those who haven't followed the discussion on IRC: I have fixed this in 
4.0.98-2.fc10 by reverting a recent kinit change which triggered this bug, but 
I think the kinit change was only uncovering a latent bug and want the real 
issue to be fixed.)

Comment 8 Kevin Kofler 2008-08-29 14:54:29 UTC
I just committed a clean fix in 4.1.1-2. Details forthcoming in an upstream bug report.

Comment 9 Kevin Kofler 2008-08-29 15:23:28 UTC
Upstream bug report: https://bugs.kde.org/show_bug.cgi?id=170043


Note You need to log in before you can comment on or make changes to this bug.