Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455124 - cpuspeed not working
Summary: cpuspeed not working
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: cpuspeed
Version: 9
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: Jarod Wilson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-12 11:48 UTC by Sander
Modified: 2008-07-13 01:55 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-13 01:55:04 UTC


Attachments (Terms of Use)

Description Sander 2008-07-12 11:48:59 UTC
Description of problem:
The CPU is always running on the full clock speed. Cpuspeed is unable to start.

Version-Release number of selected component (if applicable):
cpuspeed v1.2.1

How reproducible:

Steps to Reproduce:
1. Boot system
2. Try to start cpuspeed (service cpuspeed start)
  
Actual results:
[root] service cpuspeed status
cpuspeed is stopped

Expected results:
[root] service cpuspeed status
cpuspeed started

Additional info:
Because cpuspeed is unable to start I tried to insert the module manually.

[root] modprobe acpi-cpufreq
FATAL: Error inserting acpi_cpufreq
(/lib/modules/2.6.25.9-76.fc9.x86_64/kernel/arch/x86/kernel/cpu/cpufreq/acpi-cpufreq.ko):
No such device

[root] ls /lib/modules/2.6.25.9-76.fc9.x86_64/kernel/arch/x86/kernel/cpu/cpufreq
acpi-cpufreq.ko  powernow-k8.ko

System is unable to find acpi_cpufreq.ko, but it does exist.

* cpuinfo
Intel(R) Core(TM)2 Duo CPU     E6750  @ 2.66GHz

Comment 1 Jarod Wilson 2008-07-13 01:55:04 UTC
That cpu should be using acpi-cpufreq. The "No such device" upon modprobing it
indicates either your bios is broken, or frequency scaling is disabled in the
bios. Please double-check your bios settings, and if they claim frequency
scaling is enabled, check for a bios update, apply it and see what you can see.
Chances are rather slim this is actually a software bug.


Note You need to log in before you can comment on or make changes to this bug.