Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455123 - IndexOptions directive: funny characters when displaying files with accents
Summary: IndexOptions directive: funny characters when displaying files with accents
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: httpd
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Joe Orton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-12 11:44 UTC by Steven Moix
Modified: 2009-02-23 14:03 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-02-23 14:03:55 UTC


Attachments (Terms of Use)

Description Steven Moix 2008-07-12 11:44:27 UTC
Description of problem: 
With the default IndexOptions directive in httpd.conf (IndexOptions
FancyIndexing VersionSort NameWidth=* HTMLTable), files with accents (é, ü,
à...) aren't displayed correctly.

Version-Release number of selected component (if applicable): 
httpd-2.2.8-3.i386, but probably with each other version too.

How reproducible:
On every Fedora installation with the default configuration.


Steps to Reproduce:
1. Install httpd
2. Create a file with accents in it's name, for example été.txt
3. Browse to the directory with a browser
  
Actual results:
Accents aren't displayed correctly.

Expected results:
Display accents in file names.

Additional info:
By modifying the IndexOptions directive to "IndexOptions FancyIndexing
VersionSort NameWidth=* HTMLTable Charset=UTF-8" it solves the problem.

Comment 1 Joe Orton 2009-02-23 14:03:55 UTC
This was done in the Raw Hide (Fedora 11) package; usually we don't backport httpd.conf changes to avoid .rpmnew/etc spam, and since they won't take for many users anyway.

Thanks for the report!


Note You need to log in before you can comment on or make changes to this bug.