Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455122 - N. does not refresh automatically after copying files to the currently displayed folder
Summary: N. does not refresh automatically after copying files to the currently displa...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: nautilus
Version: 9
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tomáš Bžatek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-12 11:26 UTC by Mumrel
Modified: 2015-03-03 22:32 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-14 19:13:29 UTC


Attachments (Terms of Use)

Description Mumrel 2008-07-12 11:26:38 UTC
Description of problem:
N. does not refresh automatically after copying files to the currently displayed
folder


Version-Release number of selected component (if applicable):
Nautilus 2.22.4, nautilus-2.22.4-1.fc9.i386

How reproducible:
Always

Steps to Reproduce:
1. Open a folder in natilus, let's say /home/test/folder
2. Create a file touch /home/test/folder/file 
  
Actual results:
Nautilus does not refresh and thus displays the same folder contents as in step
1 above.

Expected results:
The open nautilus window showing /home/test/folder should be aware of the new
file, and refresh itself without manual interaction.

Additional info:
CTRL-R or F5 solves the problem, but is very, very annoying.

Comment 1 Tomáš Bžatek 2008-07-14 11:03:47 UTC
Did this happen with older Nautilus versions? Can you please post exact package
version of kernel running? Can you please check if the /proc/sys/fs/inotify
directory exists?

Comment 2 Mumrel 2008-07-14 19:12:45 UTC
Uh, in this case it's seems that I am the bug.
/proc/sys/fs/inotify exists, and therefore I tried this issue under different
useres, both nonroot and root. It workes for both of them. So I remembered, that
I ex post mounted my prior used /home/me (own disk from Fedora 7) and had some
issued with permissions, since the id of the prior fedora user and fedora 9 user
did not match.
Thus I did a chown -R me:me /home/me and after that it seems to work fine. Sorry
for the inconvenience. 


Note You need to log in before you can comment on or make changes to this bug.