Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455084 - The default bash profile on RHE screws up window managers on other systems.
Summary: The default bash profile on RHE screws up window managers on other systems.
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: bash
Version: 5.0
Hardware: All
OS: Linux
low
high
Target Milestone: rc
: ---
Assignee: Roman Rakus
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-11 20:57 UTC by Mike Meyer
Modified: 2014-01-13 00:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-03-12 14:30:10 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Mike Meyer 2008-07-11 20:57:03 UTC
Description of problem:

The default bash profile on RHE screws up window managers on other systems.

Version-Release number of selected component (if applicable):


How reproducible:

Log into a desktop system with a window manager that actually manages windows
and cares about window titles for such (ratpoison and plpwm come to mind) and
open an xterm, or an OSX system with Terminal configured with the command key in
title option enabled and open a couple of Terminal windows.

Steps to Reproduce:
1. Log into a red hat system that uses the default bash_profile from that
terminal window. For Terminal, you may have to repeate this process a few times.
2a. Invoke a window manager operation that depends on the title of the window.
2b. Try switching Terminal windows with the windows command key.
  
Actual results:
Windows that should be automatically placed and open are left iconified;
Terminal windows won't switch, because the command key is simply no longer
functional.

Expected results:

That the windows behave as documented - being opened and properly placed as
indicated by the title the user specified, and that the command keys continue
operating as normal.

Additional info:

This problem is made nastier to solve than one would expect on a Unix system
because the undesirable behavior is set in the system-wide rc's, rather than in
the user-controlled rc's provided to new accounts, so that instead of just
finding the place it's set and commenting it out or deleting it, the user has to
learn how all the bash startup scripts interoperate and arrange to turn it off
in the appropriate place for the various scripts - if possible.

Comment 1 RHEL Product and Program Management 2009-11-06 18:59:06 UTC
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".

Comment 3 RHEL Product and Program Management 2010-08-09 19:06:26 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 4 Roman Rakus 2011-01-18 15:25:28 UTC
I'm sorry, but I can't reproduce this bug. However, is this bug similar to bug 620408? Can you please try to change PROMPT_COMMAND from using echo to use printf?

Comment 6 Mike Meyer 2011-08-17 21:14:19 UTC
No, this is not similar to bug 620408. The PROMPT_COMMAND is doing exactly what it was intended to do. However, that behavior *breaks* window managers on other systems. Besides the two already mentioned, this may create problems for Windows users using tools like WinSize or Winsize2.

Comment 7 RHEL Product and Program Management 2011-09-23 00:30:00 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 8 Roman Rakus 2012-05-09 10:54:34 UTC
Did you try to change PROMPT_COMMAND? Is this bug still valid?

Comment 9 Mike Meyer 2012-05-09 12:54:42 UTC
Yes, I changed PROMPT_COMMAND to use printf. It did not solve the problem. The problem is not that garbage is showing up in the window title, the problem is that RHEL is changing the window title on windows that it should be leaving alone.

Comment 10 Roman Rakus 2013-03-12 14:30:10 UTC
RHEL-5.10 (the next RHEL-5 minor release) is going to be the first production phase 2 [1] release of RHEL-5. Since phase 2 we'll be addressing only security and critical issues.

[1] https://access.redhat.com/support/policy/updates/errata/


Note You need to log in before you can comment on or make changes to this bug.