Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455034 - Pushing packages to a channel by pubilshing an Errata fails.
Summary: Pushing packages to a channel by pubilshing an Errata fails.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: Server
Version: 0.1
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Justin Sherrill
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
: 464700 (view as bug list)
Depends On:
Blocks: space03
TreeView+ depends on / blocked
 
Reported: 2008-07-11 15:57 UTC by John Hodrien
Modified: 2009-09-17 07:00 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-17 07:00:52 UTC


Attachments (Terms of Use)
Email WEB TRACEBACK (deleted)
2008-07-11 15:57 UTC, John Hodrien
no flags Details

Description John Hodrien 2008-07-11 15:57:43 UTC
Description of problem:

Pushing packages to a channel by pubilshing an Errata fails.  As a result
packages have to be manually added to the affected channel before publishing the
Errata.

Version-Release number of selected component (if applicable):

spacewalk-0.1-7

How reproducible:

I've only managed to get it to /not/ do this once, but I've reproduced it on a
pair of servers, one 32bit one 64bit.

Steps to Reproduce:
1.  Create an Errata including packages from a channel
2.  Publish Errata to a different channel that doesn't include the packages
3.  Accept pushing the packages to the channel.
  
Actual results:

Server error and the packages are not added to the channel.  In addition the
Errata is not successfully published as a result.  Email attached.

Expected results:

It works, the errata is published, and the packages are added to the channel.

Additional info:

Comment 1 John Hodrien 2008-07-11 15:57:43 UTC
Created attachment 311596 [details]
Email WEB TRACEBACK

Comment 2 Justin Sherrill 2008-10-13 20:42:16 UTC
I think i finally figured this one out.  Wasn't able to reproduce for the longest time, but I believe it is related to whether or not you have 32bit and 64bit channels synced.  If that is the case (and I'm testing that out right now), then I pretty sure I've got a fix for it.

Comment 3 John Hodrien 2008-10-14 09:15:09 UTC
(In reply to comment #2)
> Wasn't able to reproduce for the longest time, but I believe it is related to
> whether or not you have 32bit and 64bit channels synced.

For the record I will have had 64bit and 32bit CentOS 5.2 pushed (with clashing md5summed packages replaced with the 64bit build just to make it work with 0.1).

Comment 4 Justin Sherrill 2008-10-14 20:47:56 UTC
Should be fixed now (and released with 0.3)
 4acecfe..1bb2fa6

Comment 5 Justin Sherrill 2008-11-03 22:14:19 UTC
*** Bug 464700 has been marked as a duplicate of this bug. ***

Comment 6 Jesus M. Rodriguez 2008-11-04 17:25:39 UTC
verified

Comment 7 Brandon Perkins 2008-11-07 02:20:56 UTC
Removing bug 455034 blocks bug 470180.

Comment 8 Miroslav Suchý 2009-09-17 07:00:52 UTC
Spacewalk has been released for some time.


Note You need to log in before you can comment on or make changes to this bug.