Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455021 - tor-lsb installation fails on x86_64
Summary: tor-lsb installation fails on x86_64
Keywords:
Status: CLOSED DUPLICATE of bug 375361
Alias: None
Product: Fedora
Classification: Fedora
Component: tor
Version: 9
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: Enrico Scholz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-11 14:44 UTC by Sameh Attia
Modified: 2008-07-20 11:55 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-20 11:55:05 UTC


Attachments (Terms of Use)
libdir fix for x86_64 platforms (deleted)
2008-07-11 14:44 UTC, Sameh Attia
no flags Details | Diff

Description Sameh Attia 2008-07-11 14:44:15 UTC
Description of problem:
When installing the below version using apt-get the installation fails with the
following error.

/var/tmp/rpm-tmp.20506: line 1: /usr/lib/lsb/install_initd: No such file or
directory
error: %post(tor-lsb-0.1.2.19-1.fc9.x86_64) scriptlet failed, exit status 127

Also this happens when removing it too.

Version-Release number of selected component (if applicable):
0.1.2.19-1.fc9.x86_64

How reproducible:
Just install the tor package and the error above will appear or you can remove
it too and will happen.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Error message.

Expected results:
Installs cleanly.

Additional info:
I guessed it should be a problem with the spec file in the post and preun
sections which does not account for x86_64 platforms where the lsb scripts are
under /usr/lib64 not /usr/lib of i38t6 platforms. So I did download the SRPM and
modified the spec file and attached a patch that fixes this problem.

Comment 1 Sameh Attia 2008-07-11 14:44:15 UTC
Created attachment 311586 [details]
libdir fix for x86_64 platforms

Comment 2 Enrico Scholz 2008-07-20 11:55:05 UTC

*** This bug has been marked as a duplicate of 375361 ***


Note You need to log in before you can comment on or make changes to this bug.