Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455016 - login shell can not be suspended by using suspend command.
Summary: login shell can not be suspended by using suspend command.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: man-pages-ja
Version: 5.3
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Akira TAGOH
QA Contact: QE Internationalization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-11 13:55 UTC by Adam Stokes
Modified: 2018-10-19 20:04 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-09-03 08:52:11 UTC
Target Upstream Version:


Attachments (Terms of Use)
ja man page update (deleted)
2008-07-11 13:55 UTC, Adam Stokes
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0266 normal SHIPPED_LIVE man-pages-ja bug fix update 2008-09-03 08:51:48 UTC

Description Adam Stokes 2008-07-11 13:55:48 UTC
Description of Problem:
We tested suspend command.

There is a comment in the manpage of suspend.
suspend [-f]
   The -f option says not to complain if this is a login shell; just suspend
   anyway.

Please see the Japanese_suspend_man.txt in the additional info for JPN man.
The contents in this man page can be understood like "suspend command" works in
any case.
However, when user executes suspend command on login shell during remote
connecting, the error messages is output.

[error message]
# suspend
-bash: suspend: cannot suspend a login shell

The result is different from man page's description.

We hope that manpage of suspend is fixed, because we think man page should be
modified to get higher quality.

We will suggest to correct man page as follows:

[draft manpage of suspend]
The suspend command can not suspend the login shell.
However, when -f option is specified, suspend command can suspend even login shell.


Version-Release number of selected component:

Red Hat Enterprise Linux Server release 5.1 (Tikanga)
Architecture: ia64
Kernel Version: kernel-2.6.18-53.el5
bash-3.1-16.1

Drivers or hardware or architecture dependency:
None.

How reproducible:
Always

Step to Reproduce:
Execute suspend command on login shell during remote connecting.

# suspend
-bash: suspend: cannot suspend a login shell


Actual Results:
Description in man page is different from actual operation.

Expected Results:
Description in man page is same with actual operation.  

Summary of actions taken to resolve issue:
None.


Additional Info:

English man page update set in BZ453409

Comment 1 Adam Stokes 2008-07-11 13:55:48 UTC
Created attachment 311577 [details]
ja man page update

Comment 6 Akira TAGOH 2008-08-23 08:08:00 UTC
Fixed in 20060815-9.el5.

Comment 11 errata-xmlrpc 2008-09-03 08:52:11 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0266.html


Note You need to log in before you can comment on or make changes to this bug.