Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454996 - [kdump] not working on HP-XW4800
Summary: [kdump] not working on HP-XW4800
Keywords:
Status: CLOSED DUPLICATE of bug 456638
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel
Version: 5.2
Hardware: x86_64
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Vivek Goyal
QA Contact: Martin Jenner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-11 11:14 UTC by Qian Cai
Modified: 2008-10-15 14:25 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-10-15 14:25:53 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Qian Cai 2008-07-11 11:14:04 UTC
Description of problem:
On HP-XW4800 64bit box, Kdump does not work out of box. It requires to add a
"noapic" argument to Kdump Kernel. Otherwise, it hangs,

hp-xw4800-01.rhts.bos.redhat.com login: SysRq : Trigger a crashdump
Linux version 2.6.18-92.el5 (brewbuilder@ls20-bc2-13.build.redhat.com) (gcc
version 4.1.2 20071124 (Red Hat 4.1.2-41)) #1 SMP Tue Apr 29 13:16:15 EDT 2008
Command line: ro root=/dev/VolGroup00/LogVol00 console=ttyS0,115200  irqpoll
maxcpus=1 reset_devices memmap=exactmap memmap=640K@0K memmap=5116K@16384K
memmap=125300K@22140K elfcorehdr=147440K
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000100 - 0000000000095800 (usable)
 BIOS-e820: 0000000000095800 - 00000000000a0000 (reserved)
 BIOS-e820: 0000000000100000 - 00000000defbc800 (usable)
 BIOS-e820: 00000000defbc800 - 00000000e0000000 (reserved)
 BIOS-e820: 00000000f8000000 - 00000000fc000000 (reserved)
 BIOS-e820: 00000000fec00000 - 00000000fed40000 (reserved)
 BIOS-e820: 00000000fed45000 - 0000000100000000 (reserved)
 BIOS-e820: 0000000100000000 - 0000000120000000 (usable)
user-defined physical RAM map:
 user: 0000000000000000 - 00000000000a0000 (usable)
 user: 0000000001000000 - 00000000014ff000 (usable)
 user: 000000000159f000 - 0000000008ffc000 (usable)
DMI 2.5 present.
ACPI: Unable to map XSDT header
No NUMA configuration found
Faking a node at 0000000000000000-0000000008ffc000
Bootmem setup node 0 0000000000000000-0000000008ffc000
Memory for crash kernel (0x0 to 0x0) notwithin permissible range
disabling kdump
Intel MultiProcessor Specification v1.4
    Virtual Wire compatibility mode.
OEM ID: COMPAQ   Product ID: Workstation  APIC at: 0xFEE00000
Processor #0 6:10 APIC version 16
Processor #2 6:10 APIC version 16
Processor #4 6:10 APIC version 16
Processor #6 6:10 APIC version 16
I/O APIC #1 Version 17 at 0xFEC00000.
I/O APIC #2 Version 17 at 0xFEC10000.
Setting APIC routing to physical flat
Processors: 4
Nosave address range: 00000000000a0000 - 0000000001000000
Nosave address range: 00000000014ff000 - 000000000159f000
Allocating PCI resources starting at 10000000 (gap: 8ffc000:f7004000)
SMP: Allowing 8 CPUs, 4 hotplug CPUs
Built 1 zonelists.  Total pages: 32238
Kernel command line: ro root=/dev/VolGroup00/LogVol00 console=ttyS0,115200 
irqpoll maxcpus=1 reset_devices memmap=exactmap memmap=640K@0K
memmap=5116K@16384K memmap=125300K@22140K elfcorehdr=147440K
Misrouted IRQ fixup and polling support enabled
This may significantly impact system performance
Initializing CPU#0
PID hash table entries: 512 (order: 9, 4096 bytes)
irq 42, desc: ffffffff803b8d80, depth: 1, count: 0, unhandled: 0
->handle_irq():  ffffffff800b723d, handle_bad_irq+0x0/0x1f6
->chip(): ffffffff802f1b80, 0xffffffff802f1b80
->action(): 0000000000000000
  IRQ_DISABLED set
unexpected IRQ trap at vector 2a
Console: colour VGA+ 80x25
Dentry cache hash table entries: 16384 (order: 5, 131072 bytes)
Inode-cache hash table entries: 8192 (order: 4, 65536 bytes)
Checking aperture...
Memory: 118672k/147440k available (2457k kernel code, 12384k reserved, 1246k
data, 196k init)
Calibrating delay using timer specific routine.. 4274.57 BogoMIPS (lpj=2137288)
Security Framework v1.0.0 initialized
SELinux:  Initializing.
selinux_register_security:  Registering secondary module capability
Capability LSM initialized as secondary
Mount-cache hash table entries: 256
CPU: L1 I cache: 32K, L1 D cache: 32K
CPU: L2 cache: 256K
CPU: L3 cache: 4096K
using mwait in idle threads.
CPU: Physical Processor ID: 0
CPU: Processor Core ID: 3
MCE: warning: using only 9 banks
SMP alternatives: switching to UP code
Using IO-APIC 1
Using IO-APIC 2
GSI 16 sharing vector 0x89 and IRQ 16
GSI 17 sharing vector 0x91 and IRQ 17
GSI 18 sharing vector 0x99 and IRQ 18
GSI 19 sharing vector 0xA1 and IRQ 19
GSI 20 sharing vector 0xA9 and IRQ 20
GSI 21 sharing vector 0xB1 and IRQ 21
GSI 22 sharing vector 0xB9 and IRQ 22
GSI 23 sharing vector 0xC1 and IRQ 23
GSI 40 sharing vector 0xC9 and IRQ 40
GSI 41 sharing vector 0xD1 and IRQ 41
GSI 42 sharing vector 0xD9 and IRQ 42
GSI 43 sharing vector 0xE1 and IRQ 43
Using local APIC timer interrupts.
result 8333588
Detected 8.333 MHz APIC timer.
Brought up 1 CPUs
testing NMI watchdog ... OK.
time.c: Using 1.193182 MHz WALL PIT GTOD PIT/TSC timer.
time.c: Detected 2133.404 MHz processor.
checking if image is initramfs... it is
Freeing initrd memory: 3002k freed
NET: Registered protocol family 16
ACPI Exception (utmutex-0262): AE_BAD_PARAMETER, Thread 8C287A0 could not
acquire Mutex [2] [20060707]
No dock devices found.
ACPI Exception (utmutex-0262): AE_BAD_PARAMETER, Thread 8C287A0 could not
acquire Mutex [2] [20060707]
PCI: Using configuration type 1
ACPI: Interpreter disabled.
Linux Plug and Play Support v0.97 (c) Adam Belay
pnp: PnP ACPI: disabled
usbcore: registered new driver usbfs
usbcore: registered new driver hub
PCI: Probing PCI hardware
PCI: Transparent bridge - 0000:00:1e.0
PCI: Using IRQ router PIIX/ICH [8086/3a16] at 0000:00:1f.0
PCI->APIC IRQ transform: 0000:00:1a.0[A] -> IRQ 169
PCI->APIC IRQ transform: 0000:00:1a.1[B] -> IRQ 177
PCI->APIC IRQ transform: 0000:00:1a.2[C] -> IRQ 185
PCI->APIC IRQ transform: 0000:00:1a.7[C] -> IRQ 185
PCI->APIC IRQ transform: 0000:00:1b.0[A] -> IRQ 177
PCI->APIC IRQ transform: 0000:00:1c.5[B] -> IRQ 177
PCI->APIC IRQ transform: 0000:00:1d.0[A] -> IRQ 169
PCI->APIC IRQ transform: 0000:00:1d.1[B] -> IRQ 177
PCI->APIC IRQ transform: 0000:00:1d.2[C] -> IRQ 185
PCI->APIC IRQ transform: 0000:00:1d.7[A] -> IRQ 169
PCI->APIC IRQ transform: 0000:00:1f.2[B] -> IRQ 153
PCI->APIC IRQ transform: 0000:10:00.0[A] -> IRQ 201
PCI: using PPB 0000:00:1c.5[A] to get irq 20
PCI->APIC IRQ transform: 0000:07:00.0[A] -> IRQ 169
NetLabel: Initializing
NetLabel:  domain hash size = 128
NetLabel:  protocols = UNLABELED CIPSOv4
NetLabel:  unlabeled traffic allowed by default
PCI-GART: No AMD northbridge found.
PCI: Bridge: 0000:00:01.0
  IO window: disabled.
  MEM window: disabled.
  PREFETCH window: disabled.
PCI: mem resource #6:20000@f0000000 for 0000:10:00.0 was not allocated.
PCI: Bridge: 0000:00:03.0
  IO window: e000-efff
  MEM window: f0000000-f2ffffff
  PREFETCH window: e0000000-efffffff
PCI: Bridge: 0000:00:07.0
  IO window: disabled.
  MEM window: disabled.
  PREFETCH window: disabled.
PCI: Bridge: 0000:00:1c.0
  IO window: disabled.
  MEM window: disabled.
  PREFETCH window: disabled.
PCI: Bridge: 0000:00:1c.5
  IO window: disabled.
  MEM window: f3000000-f30fffff
  PREFETCH window: 10000000-100fffff
PCI: Bridge: 0000:00:1e.0
  IO window: disabled.
  MEM window: disabled.
  PREFETCH window: disabled.
NET: Registered protocol family 2
IP route cache hash table entries: 1024 (order: 1, 8192 bytes)
TCP established hash table entries: 4096 (order: 4, 65536 bytes)
TCP bind hash table entries: 2048 (order: 3, 32768 bytes)
TCP: Hash tables configured (established 4096 bind 2048)
TCP reno registered
audit: initializing netlink socket (disabled)
audit(1215770017.970:1): initialized
Total HugeTLB memory allocated, 0
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 512 (order 0, 4096 bytes)
Initializing Cryptographic API
ksign: Installing public key data
Loading keyring
- Added public key 6E24E25C96667C37
- User ID: Red Hat, Inc. (Kernel Module GPG key)
io scheduler noop registered
io scheduler anticipatory registered
io scheduler deadline registered
io scheduler cfq registered (default)
assign_interrupt_mode Found MSI capability
assign_interrupt_mode Found MSI capability
assign_interrupt_mode Found MSI capability
assign_interrupt_mode Found MSI capability
assign_interrupt_mode Found MSI capability
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
Real Time Clock Driver v1.12ac
Non-volatile memory driver v1.2
Linux agpgart interface v0.101 (c) Dave Jones
Serial: 8250/16550 driver $Revision: 1.90 $ 4 ports, IRQ sharing enabled


Version-Release number of selected component (if applicable):
kernel-2.6.18-92.el5
kexec-tools-1.102pre-21.el5

How reproducible:
Always

Steps to Reproduce:
1. configure Kdump with 128M@16M.
2. SysRq-C

Additional info:

[root@hp-xw4800-01 ~]# dmidecode
# dmidecode 2.7
SMBIOS 2.5 present.
66 structures occupying 1916 bytes.
Table at 0x000EA0C0.

Handle 0x0001, DMI type 0, 24 bytes.
BIOS Information
	Vendor: Hewlett-Packard
	Version: 786G3 v00.17
	Release Date: 06/04/2008
	Address: 0xE0000
	Runtime Size: 128 kB
	ROM Size: 2048 kB
	Characteristics:
		PCI is supported
		PNP is supported
		BIOS is upgradeable
		BIOS shadowing is allowed
		Boot from CD is supported
		Selectable boot is supported
		EDD is supported
		Japanese floppy for Toshiba 1.2 MB is supported (int 13h)
		3.5"/720 KB floppy services are supported (int 13h)
		Print screen service is supported (int 5h)
		8042 keyboard services are supported (int 9h)
		Serial services are supported (int 14h)
		Printer services are supported (int 17h)
		ACPI is supported
		USB legacy is supported
		LS-120 boot is supported
		ATAPI Zip drive boot is supported
		BIOS boot specification is supported
		Function key-initiated network boot is supported
		Targeted content distribution is supported
	BIOS Revision: 0.17

Comment 1 Prarit Bhargava 2008-10-15 14:25:53 UTC
This also is a dup of 456638.  The original failure is no longer reproducible, however, the new failure (loop GPE errors) is the same as 456638.

P.

*** This bug has been marked as a duplicate of bug 456638 ***


Note You need to log in before you can comment on or make changes to this bug.