Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454953 - imapsync doesn't work with current perl-mail-imapclient
Summary: imapsync doesn't work with current perl-mail-imapclient
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: imapsync
Version: 9
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Marek Mahut
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-11 01:00 UTC by Lev Novikov
Modified: 2008-09-10 07:15 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-09-10 07:15:48 UTC


Attachments (Terms of Use)

Description Lev Novikov 2008-07-11 01:00:37 UTC
Description of problem:
imapsync doesn't work with current perl-mail-imapclient

Version-Release number of selected component (if applicable):
imapsync-1.252-2 (and 1.255)
perl-Mail-IMAPClient-3.05-1

Steps to Reproduce:
1. yum install imapsync
2. run imapsync (without any parameters)
  
Actual results:

Subroutine Authuser redefined at /usr/bin/imapsync line 2564.
imapsync needs perl lib Mail::IMAPClient release 2.2.9 exactly, future imapsync
release may suppoort 3.0.x, but sorry not now. See file BUG_IMAPClient_3.xx


Additional info:
when i build from source.rpm and install old version of perl-Mail-IMAPClient (2.2.9)
imapsync run correctly without any problem

Comment 1 Pavel Alexeev 2008-07-14 00:38:49 UTC
In my spec (it in my repository http://hubbitus.net.ru/rpm/Fedora8/imapsync/
with additional patches) I just using:
BuildRequires:>perl(Mail::IMAPClient) < 2.99
Requires:><--->perl(Mail::IMAPClient) < 2.99

Comment 2 Pavel Alexeev 2008-07-14 00:40:07 UTC
Excuse me (I can not edit comment?):

BuildRequires: perl(Mail::IMAPClient) < 2.99
Requires:      perl(Mail::IMAPClient) < 2.99

Comment 3 Lubomir Rintel 2008-08-08 09:09:55 UTC
Actually, imapsync works with Mail::IMAPClient >= 3, there are just two known bugs (see BUG_IMAPClient_3.xx), albeit quite serious (at least the ssl one:)

BUGS found with Mail-IMAPClient-3.05/

1) --ssl* bugs. 

   30 timeout.

2) --expunge2 does not expunge anything.

Nevertheless, I've changed the code to fall back to override the Authuser function only with older IMAPClients, so permanent errors are hopefully gone. I've done no testing at all, so I'll appreciate any feedback. Thanks!

Comment 4 Lubomir Rintel 2008-08-08 09:11:26 UTC
fc10 build is here [1], please let me know if you need package for f9 as well, unless you are able rebuild it yourself:

[1] http://koji.fedoraproject.org/koji/buildinfo?buildID=58990

Comment 5 Rick Richardson 2008-08-11 14:49:57 UTC
$ gmail-backup 
Subroutine Authuser redefined at /usr/bin/imapsync line 2557.
imapsync needs perl lib Mail::IMAPClient release 2.2.9 exactly, future imapsync release may suppoort 3.0.x, but sorry not now. See file BUG_IMAPClient_3.xx
# Looks like your test died before it could output anything.

Latest update from fc9.

Comment 6 Lubomir Rintel 2008-08-11 17:18:26 UTC
Rick: Try the package from comment #4 and please report if it works for you.

Comment 7 Lev Novikov 2008-08-12 14:41:10 UTC
Package from comment #4 works for me

Comment 8 Lubomir Rintel 2008-08-15 08:51:44 UTC
Lev: Thanks for the feedback.

The package had been commited into Fedora 9 branch, but the build is pending the resolution of some infrastructure trouble now.

I'd appreciate if anyone else that can test here tried the new package from comment #4 so we can check how severe are the known bugs of this release before we push it.

Thanks!

Comment 9 Fedora Update System 2008-08-24 14:56:18 UTC
imapsync-1.255-3.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/imapsync-1.255-3.fc9

Comment 10 Fedora Update System 2008-09-10 07:15:45 UTC
imapsync-1.255-3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.