Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454948 - cursor movement is constrained
Summary: cursor movement is constrained
Keywords:
Status: CLOSED DUPLICATE of bug 454938
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Berrange
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 238825
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-10 23:12 UTC by Jens Petersen
Modified: 2008-07-11 08:35 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-11 08:35:19 UTC


Attachments (Terms of Use)

Description Jens Petersen 2008-07-10 23:12:17 UTC
+++ This bug was initially created as a clone of Bug #238825 +++

Description of problem:
When using virtual graphical consoles after the pointer is grabbed
often the cursor is constrained away from one edges of the screen,
which is annoying.

Steps to Reproduce:
1. start virtual machine from virt-manager
2. click to stay in window
3. move cursor around
  
Actual results:
Usually some part (edge) of the screen can't be reached without moving
first to the opposite edge.

Expected results:
Pointer to be directly movable to any part of screen.

Additional info:
This does not seem to happen if one runs qemu directly for instance.

-- Additional comment from bryan.christ@hp.com on 2007-06-29 11:39 EST --
I have this problem too.  I've noticed that by moving the mouse really fast, it
is possible to "break through" the artificial barrier.

-- Additional comment from ville.skytta@iki.fi on 2007-07-01 10:44 EST --
Same effects observed here, and the trick in comment #1 also works around it for
me (by moving really fast to the opposite direction from the constrained edge).
 The workaround isn't enough to make the machines actually usable though, it has
to be done all the time.  Tested only with a QEMU VM, F-7 x86_64.  Plain QEMU
works fine.

-- Additional comment from petersen@redhat.com on 2007-07-01 22:02 EST --
I haven't tried "moving really fast" but for me moving to the opposite
edge and then returning clears the constraint for me.  Yes it is very annoying.

-- Additional comment from bugzilla@redhat.com on 2007-07-24 22:10 EST --
change QA contact

-- Additional comment from berrange@redhat.com on 2007-09-27 17:11 EST --
This should be much improved in current (F8) rawhide version, since we have
re-written the VNC widget used for the console. Please let me know if it still
gets 'stuck' on invisible walls with virt-manager 0.5.1 or later.


-- Additional comment from petersen@redhat.com on 2007-10-15 20:58 EST --
Thanks - looks good to me now. :)

-- Additional comment from bryan.christ@hp.com on 2008-07-10 15:01 EST --
This problem has resurfaced with F9 and latest stable updates via yum.

-- Additional comment from berrange@redhat.com on 2008-07-10 17:24 EST --
Do *NOT* re-open old bugs. Please file a new bug and if relevant add a comment
refering to the original bug.


-- Additional comment from petersen@redhat.com on 2008-07-10 19:08 EST --
Yes thanks for bringing this up - it has been back for too long. :-/

Comment 1 Jens Petersen 2008-07-10 23:15:52 UTC
It is particularly painful when using a virtual console.

It took me a long time to understand that the problem is the invisible real X
pointer
underneath which moves much quicker than the virtual pointer and hence reaches
the edges
of the console very quickly before the visible cursor has time to move.  This became
clear when watching the real and virtual pointer when they are separated.

Comment 2 Daniel Berrange 2008-07-11 08:35:19 UTC

*** This bug has been marked as a duplicate of 454938 ***


Note You need to log in before you can comment on or make changes to this bug.