Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454946 - Hal fails after normal update
Summary: Hal fails after normal update
Keywords:
Status: CLOSED DUPLICATE of bug 452701
Alias: None
Product: Fedora
Classification: Fedora
Component: hal
Version: 8
Hardware: x86_64
OS: Linux
low
urgent
Target Milestone: ---
Assignee: David Zeuthen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-10 22:39 UTC by Ricardo Berlasso
Modified: 2013-03-06 03:56 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-09-08 08:51:24 UTC


Attachments (Terms of Use)

Description Ricardo Berlasso 2008-07-10 22:39:20 UTC
Description of problem:
After the last update (June 10) the system restart by itself and during boot an
error that Hal cannot be started is shown.
After that, sound system is dead and my usb-modem (my only internet connection!)
refuses to work.
See this thread on the fedora forums:
http://forums.fedoraforum.org/showthread.php?t=194013

Comment 1 Silivrenion 2008-07-13 00:49:47 UTC
Although I experienced this same problem with Fedora 8, I decided my resolution
was to reformat and install Fedora 9. My problems have gone away, HAL correctly
starts now.

Comment 2 Brad 2008-07-13 02:39:05 UTC
After the recent updates of packages hal, hal-info, hal-libs, and hal-devel, I
had the same problem.  Reverting just hal-info from version 20080607-2 to the
FC8 base release 20071030-1 sufficed to repair my system. 

The output of hald prior to the crash:
22:14:53.134 [E] acpi.c:758: Couldn't open /proc/acpi/button/sleep: Error
opening directory '/proc/acpi/button/sleep': No such file or directory
22:14:53.134 [I] acpi.c:837: Processing sonypi display
22:14:53.134 [I] osspec.c:431: ACPI capabilities found
22:14:53.134 [I] osspec.c:439: Done synthesizing events
*** [DIE] device_info.c:rules_match_and_merge_device():1089 : Rule is NULL on jump
22:14:53.135 [D] addon-input.c:486: An error occured, exiting cleanly


My hardware: Fujitsu Lifebook P7120.

Comment 3 foot 2008-07-14 08:09:37 UTC
The same after update.
Hal 0.5.10-3.fc8.
Kernel 2.6.25.10-46.fc8

Comment 4 kyle 2008-07-15 17:36:16 UTC
i have same probelm too, but i dont know how to revert the older verson 
can you guy give me more specific solution ? 
my email : kyle_huynh205@hotmail.com

Comment 5 Steve Wilson 2008-07-16 20:57:16 UTC
I too had the same problem, it is OK to update all hal except from hal-info.
Have not gotten around yet to working out what the problem is with this.

Comment 6 Ricardo Berlasso 2008-07-17 09:20:55 UTC
(In reply to comment #4)
> i have same probelm too, but i dont know how to revert the older verson 
> can you guy give me more specific solution ? 
> my email : kyle_huynh205@hotmail.com

Just follow the fedora forum thread linked above, everything is explained there.

Comment 7 kmike 2008-08-21 20:24:20 UTC
Duplicate of bug 452701.
There are RPMs with the fix linked in that bug, too.

Comment 8 Adam Pribyl 2008-09-08 08:51:24 UTC

*** This bug has been marked as a duplicate of bug 452701 ***


Note You need to log in before you can comment on or make changes to this bug.