Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454938 - Cursor Movement is Constrained
Summary: Cursor Movement is Constrained
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gtk-vnc
Version: 10
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Berrange
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 454948 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-10 21:34 UTC by Bryan Christ
Modified: 2009-03-25 16:48 UTC (History)
8 users (show)

Fixed In Version: 0.3.8-2.fc10
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-03-18 18:59:13 UTC


Attachments (Terms of Use)

Description Bryan Christ 2008-07-10 21:34:36 UTC
Description of problem:

When using virtual graphical consoles after the pointer is grabbed
often the cursor is constrained away from one edges of the screen,
which is annoying.

Version-Release number of selected component (if applicable):

virt-manager-0.5.4-4.fc9.x86_64

How reproducible: often

Steps to Reproduce:
1. start virtual machine from virt-manager
2. click to stay in window
3. move cursor around
  
Actual results:

Usually some part (edge) of the screen can't be reached without moving
first to the opposite edge.

Additional info:

Moving the mouse really fast also seems to "break through" the artificial barrier.

This bug was noticed noticed and fixed in 2007 but appears to have resurfaced. 
The original BZ was 238825.

Comment 1 Daniel Berrange 2008-07-11 08:33:22 UTC
What gtk-vnc version ?

Please provide the guest config from 'virsh dumpxml NAME-OF-GUEST" & what OS is
installed in the guest ?

Comment 2 Daniel Berrange 2008-07-11 08:35:21 UTC
*** Bug 454948 has been marked as a duplicate of this bug. ***

Comment 3 Bryan Christ 2008-07-11 14:45:43 UTC
gtk-vnc-0.3.4-4.fc9.x86_64

I had one guest that was PC-BSD and the other WinXP.  I have already deleted
both guest images (due to another unrelated bug) but the problem surfaced even
during the install of both of these operating systems.

Comment 5 John Ruemker 2008-10-03 19:12:24 UTC
Problem still exists in rawhide

virt-manager-0.6.0-1.fc10.x86_64
gtk-vnc-0.3.7-2.fc10.x86_64

Comment 6 Cole Robinson 2009-02-15 21:57:33 UTC
Reassigning to gtk-vnc, my guess is this isn't virt-manager specific.

Comment 7 Fedora Update System 2009-02-26 15:51:30 UTC
gtk-vnc-0.3.8-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/gtk-vnc-0.3.8-2.fc10

Comment 8 Daniel Berrange 2009-02-26 15:53:29 UTC
Should be fixed in  gtk-vnc-0.3.8-2.fc10 and gtk-vnc-0.3.8-4.fc11

Comment 9 Fedora Update System 2009-02-28 03:26:56 UTC
gtk-vnc-0.3.8-2.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gtk-vnc'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2143

Comment 10 Fedora Update System 2009-03-18 18:59:06 UTC
gtk-vnc-0.3.8-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Mark McLoughlin 2009-03-25 16:48:50 UTC
Upstream discussion, for reference:

  http://mail.gnome.org/archives/gtk-vnc-list/2009-February/msg00003.html


Note You need to log in before you can comment on or make changes to this bug.