Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454903 - cpio failure on package update means package gets removed.
Summary: cpio failure on package update means package gets removed.
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Panu Matilainen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-10 17:10 UTC by Dave Jones
Modified: 2015-01-04 22:30 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-03-07 08:39:47 UTC


Attachments (Terms of Use)

Description Dave Jones 2008-07-10 17:10:28 UTC
during a yum update, I saw..

 Updating       : nfs-utils                                     [ 66/212] 
Error unpacking rpm package 1:nfs-utils-1.1.2-12.fc10.i386

and then later..
Stopping RPC idmapd: [  OK  ]
Starting RPC idmapd: [  OK  ]
Stopping NFS locking: [  OK  ]
Stopping NFS statd: [  OK  ]
Starting NFS statd: [  OK  ]
  Cleanup        : nfs-utils                                     [171/212] 

and the result is..

$ rpm -q nfs-utils
package nfs-utils is not installed


if the install stage breaks for whatever reason, we really shouldn't be running
the cleanup stage.  I'm just really thankful this happened to a bunch of
non-critical packages. if it was glibc, I'd be completely hosed.

Comment 1 Jeff Johnson 2008-07-17 12:33:24 UTC
The problem is harder to fix than what is implemented in rpm-4.4.2.3.4.5.6.7...

In general, package side effects, like Obsoletes: and/or upgrade,
are dependent on the success of the install. In your case, the
nfs-install package, which has a single dependent action, removing
the old nfs-utils package.

The general form of relations with the side effects of Obsoletes: and upgrades is many <-> many.
Consider what should happen if the nfs-utils package carried several Obsoletes: as
well as the implicit upgrade. Should the Obsoletes: be performed if the install fails?
I think not.

The many-to-many side effects dependent on the success (or failure) of
the initial install (in yr case nfs-utils) is correctly handled in the @rpm5.org
code base for several years now.

Have fun!

Comment 2 Panu Matilainen 2009-03-07 08:39:47 UTC
Fixed in rawhide now.


Note You need to log in before you can comment on or make changes to this bug.