Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454886 - AttributeError: 'CMConfig' object has no attribute 'cert_extension'
Summary: AttributeError: 'CMConfig' object has no attribute 'cert_extension'
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: func
Version: 9
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Michael DeHaan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-10 15:26 UTC by Edouard Bourguignon
Modified: 2014-01-21 23:03 UTC (History)
1 user (show)

Fixed In Version: 0.20-2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-11 18:29:46 UTC


Attachments (Terms of Use)

Description Edouard Bourguignon 2008-07-10 15:26:40 UTC
Description of problem:
func master can't connect anymore to func minions, seems func overlord client is
missing something in the config file of the certmaster (about a cert_extension
key). Parsing the config file seems incomplete.

Version-Release number of selected component (if applicable):
func-0.21-1.fc9.noarch
certmaster-0.19-1.fc9.noarch

How reproducible:
static

Steps to Reproduce:
1. install func on master and clients
2. run funcd on clients and sign the certs on the master
3. try to run func
  
Actual results:
[root@Toutatis func]# func dom0-ref0* call process list
Traceback (most recent call last):
  File "/usr/bin/func", line 12, in <module>
    cli.parse(argv)
  File "/usr/lib/python2.5/site-packages/func/overlord/command.py", line 224, in
parse
    self.handleArguments(args)
  File "/usr/lib/python2.5/site-packages/func/overlord/func_command.py", line
64, in handleArguments
    if client.is_minion(minion_string) or self._isGlob(minion_string):
  File "/usr/lib/python2.5/site-packages/func/overlord/client.py", line 153, in
is_minion
    return minions.is_minion()
  File "/usr/lib/python2.5/site-packages/func/overlord/client.py", line 143, in
is_minion
    self.get_urls()
  File "/usr/lib/python2.5/site-packages/func/overlord/client.py", line 129, in
get_urls
    self._get_all_hosts()
  File "/usr/lib/python2.5/site-packages/func/overlord/client.py", line 114, in
_get_all_hosts
    actual_gloob = "%s/%s.%s" % (self.config.certroot, each_gloob,
self.config.cert_extension)
AttributeError: 'CMConfig' object has no attribute 'cert_extension'

Expected results:
should work

Additional info:

Comment 1 Michael DeHaan 2008-07-10 16:46:15 UTC
Look for an .rpmnew file and add that new setting to the config file.

I agree that if this is not provided this should not be an error, thanks for the
report.



Comment 2 Michael DeHaan 2008-07-10 16:53:24 UTC
I've filed a Trac ticket here so it shows up in our Trac list.  

https://fedorahosted.org/func/ticket/50



Comment 3 Edouard Bourguignon 2008-07-11 07:11:55 UTC
no .rpmnew file. Even if I add the cert_extension to the certmaster minion.conf
it doesn't work. But it works if I take the latest git version.

Comment 4 Michael DeHaan 2008-07-11 12:59:53 UTC
It does not look to be a problem with a minion side config file as this is
coming from the ovelord.

Can you please try this and report the results:

find /etc/func -name "*.rpmnew" 
find /etc/certmaster -name "*.rpmnew" 

It would be working from git because if you install from there with "make
install" it would overwrite your old config file.  Or are you saying you are
rebuilding the RPM from git and installing it on the same system without
changing config files and that works?

Comment 5 Michael DeHaan 2008-07-11 18:29:46 UTC
You can ignore the above.

We failed to push the new certmaster 0.20-2 to Fedora 8/9 updates.  If you got
your update via yum, this explains it.

It is pushed now and should be on mirrors shortly.



Comment 6 Edouard Bourguignon 2008-07-13 10:12:39 UTC
great, I will try this asap.

Thanks :)


Note You need to log in before you can comment on or make changes to this bug.