Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454881 - asterisk missing default sounds, voicemail doesn't work by default
Summary: asterisk missing default sounds, voicemail doesn't work by default
Keywords:
Status: CLOSED DUPLICATE of bug 428832
Alias: None
Product: Fedora
Classification: Fedora
Component: asterisk
Version: 9
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Jeffrey C. Ollie
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-10 15:02 UTC by erikj
Modified: 2008-07-10 15:21 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-10 15:21:26 UTC


Attachments (Terms of Use)

Description erikj 2008-07-10 15:02:35 UTC
Hello.  I have the latest fedora 9 updates installed.
I'm using the testing version of the asterisk update:
asterisk-1.6.0-0.17.beta9.fc9.i386

I am moving from my own build of asterisk to trying out the fedora 9 beta
asterisk.  In my transition, I found that none of the default sounds,
which should be in /usr/share/asterisk/sounds/, seem to exist.  This makes
using asterisk voicemail difficult.  I have these packages installed:

[root@highrise ~]# rpm -qa | grep asterisk
asterisk-1.6.0-0.17.beta9.fc9.i386
asterisk-voicemail-plain-1.6.0-0.17.beta9.fc9.i386
asterisk-voicemail-1.6.0-0.17.beta9.fc9.i386
asterisk-zaptel-1.6.0-0.17.beta9.fc9.i386
[root@highrise ~]# rpm -qa | grep zaptel
zaptel-lib-1.4.9-1.fc9.i386
zaptel-1.4.9-1.fc9.i386
asterisk-zaptel-1.6.0-0.17.beta9.fc9.i386


When I tried to use the voicemail system, it failed because it wasn't able to
open the sounds.  Here is an example error message in the messages file:
[Jul  9 22:36:39] WARNING[29484] file.c: File vm-login does not exist in any format
[Jul  9 22:36:39] WARNING[29484] file.c: Unable to open vm-login (format 0x4
(ulaw)): No such file or directory
[Jul  9 22:36:39] WARNING[29484] app_voicemail.c: Couldn't stream login file


When I copied the sounds from my previous asterisk install in to position,
voicemail started to work fine.

Would it be possible to create a package with asterisk default sounds included?

I could test such a package if requested.

Comment 1 Jeffrey C. Ollie 2008-07-10 15:21:26 UTC
Unfortunately, packaging the existing sounds is not possible because they do not
have a license that is compatible with Fedora's policies.  The short term
solution is to download and install the sounds yourself.  Longer term work has
been happening on bug 428832.

*** This bug has been marked as a duplicate of 428832 ***


Note You need to log in before you can comment on or make changes to this bug.