Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454863 - testsuite regressions failed
Summary: testsuite regressions failed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: php
Version: 5.2
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Joe Orton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-10 10:29 UTC by Martin Kočí
Modified: 2009-01-20 22:05 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-20 22:05:21 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:0226 normal SHIPPED_LIVE php bug fix update 2009-01-20 16:06:27 UTC

Description Martin Kočí 2008-07-10 10:29:48 UTC
Description of problem:
The build has reported 1 extra testsuite failures: 
...build.log truncated....
TEST FAILURE: ../ext/date/tests/bug20382-2.diff --
047+ ts     = Monday 2037-09-28 17:17:17 NZDT
047- ts     = Monday 2037-09-28 17:17:17 NZST
-- ../ext/date/tests/bug20382-2.diff result ends.
...build.log truncated ....

Version-Release number of selected component (if applicable):
old-version : php-5.1.6-20.el5
new-version : php-5.1.6-20.el5_2.1

How reproducible:
Compare old build log with new one.
  
Actual results:
Tests failed    :    3 (  0.1%) (  0.3%)

Expected results:
Tests failed    :    2 (  0.1%) (  0.2%)

Comment 1 Joe Orton 2008-07-10 11:36:01 UTC
To be clear, did this test fail with both the new and old versions of php?

What version of the tzdata packaeg was used when running the test in each case?

Comment 2 Martin Kočí 2008-07-10 15:56:09 UTC
> To be clear, did this test fail with both the new and old versions of php?

no, only with new version. To be definite with new version there are 3 tests
failed and with old version there are only 2 tests failed.  
This test is extra in new version :
TEST FAILURE: ../ext/date/tests/bug20382-2.diff --
047+ ts     = Monday 2037-09-28 17:17:17 NZDT
047- ts     = Monday 2037-09-28 17:17:17 NZST

> What version of the tzdata packaeg was used when running the test in each case?

tzdata     noarch     2008b-3.el5      core              753 k



Comment 3 Joe Orton 2008-07-10 16:08:08 UTC
OK.  It looks like this test case is wrong for the current tzdata, it has been
fixed upstream.  So the result is a false negative; I'm not sure why the test
case wouldn't fail with the old packages.

We can fix the test case for future updates.

Comment 4 RHEL Product and Program Management 2008-07-10 16:22:09 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 9 errata-xmlrpc 2009-01-20 22:05:21 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0226.html


Note You need to log in before you can comment on or make changes to this bug.