Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454843 - init segfault on first boot in a fakeraid (dmraid) setup
Summary: init segfault on first boot in a fakeraid (dmraid) setup
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: dmraid
Version: 9
Hardware: All
OS: Linux
low
urgent
Target Milestone: ---
Assignee: Heinz Mauelshagen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-10 06:03 UTC by n0n0
Modified: 2009-04-22 13:03 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-04-22 13:03:35 UTC


Attachments (Terms of Use)

Description n0n0 2008-07-10 06:03:03 UTC
+++ This bug was initially created as a clone of Bug #313411 +++

Description of problem:
Fedora 8 (KDE test2) livecd detects all raid volumes and installs fine, but on 
boot I get:

"init[1]: sefault at 00000010 eip 00159efa esp bf9072bc error 4"

/boot is on a disk outside of the raid array and / is on a fakeraid (dmraid) 
raid0 volume (second partition after windows).


Steps to Reproduce:
1. Boot fedora8.KDE.test2 livecd
2. Install / on raid0 volume (second partition) and /boot on a non-member 
(outside raid) disk
3. Boot
  
Actual results:
Boot fails with init segfault

-- Additional comment from bugzilla.redhat@sakher.fr on 2007-12-05 16:06 EST --
I have the same problem at boot.

"init[1]: segfault at 0000000000000010 rip 00002aaaab0f8e84 rsp 00007fff80de44b8
error 4"

Fedora 8 (x86-64) system is not on a raid disk (ATA Disk). Raid1 volume is a
ntfs volume (SATA Disks).





-- Additional comment from galerienv@yahoo.fr on 2007-12-07 13:08 EST --
another one.

-- Additional comment from amdeusro@yahoo.com on 2007-12-09 07:44 EST --
Same first-boot error here:

init[1]: segfault at 0000000000000010 rip 00002aaaab0f8e84 rsp 00007fffc0186858
error 4

Fedora 8 x86-64 installed on PATA drive. Two more SATA drives in RAID1.
Installation works only if no partition from RAID1 volume is mounted, else there
is an error after formatting / partition.

-- Additional comment from avt.online@gmail.com on 2008-02-21 14:30 EST --
I have exact same problem with both 64 and 32 bit installs. I have Intel Dual
Core CPU, 2 SATA drives as RAID1 (Vista), 1 IDE (target for FC8 install) and 1
SATA standalone drive (Windows XP). 

Here is the last screen for 32 bit install:
Loading dM-snapshot.ko Module
device-mapper: table: device 8:0 too small for target
device-mapper: table: 253:0: mirror: Device Lookup failure
device-mapper: ioctl: error adding target to table
device-Mapper: reload ioctl failed: No such device or address
Trying to resume froM LABEL=SWAP-sdc2
device-mapper: table ioctl failed: No such device or address
device-mapper: deps ioctl failed: No such device or address
init[1]: segfault at 00000010 eip 00159efa esp bfb194bc error 4
nash received SIGSEGV! Backtrace (14):
/bin/nash[0x805314a]
[0x12d440]
/usr/lib/libnash.so.6.0.19(nashDmDevGetNaMe+0x5a)[0x13c36b]
/usr/lib/libnash.so.6.0.19[0x1389e3]
/usr/lib/libnash.so.6.0.19[0x138b11]
/usr/lib/libnash.so.6.0.19(nashBdevIterNext+0x10b)[0x138f9f]
/usr/lib/libnash.so.6.0.19[8x139251]
/usr/lib/libnash.so.6.0.19(nashFindFsByLabel+0x2e)[0xl392a4]
/usr/lib/libnash.so.6.0.19(nashAGetPathBySpec+0x69)[0xl3942a]
/bin/nash[0x804f135l
/bin/nash[0x8052fb2l
/bin/nash[0x80536c3]
/lib/libc.so.6(__libc_start_main+0xe0)[0x461390]
/bin/nash[0x804ae61]

-- Additional comment from dm@mensa.se on 2008-02-22 02:01 EST --
This is strange. This bug is classed as an initng bug, yet I see nothing in any
of the comments above about any of you actually using initng. Am I wrong here or
should it be moved to the sysvinit component instead?

-- Additional comment from dm@mensa.se on 2008-03-23 11:44 EST --
Since I didn't get any replies to comment #5 I'll assume that I'm right and that
this hasn't got anything with initng to do. Since my best guess is it has with
device-mapper to do I'll put it there...

-- Additional comment from ikent@redhat.com on 2008-03-23 23:48 EST --
Is a RAID controller present?
What is it?

-- Additional comment from avt.online@gmail.com on 2008-03-24 02:19 EST --
RAID is present - Silicon Image Sil 3114 SATARaid Controller


-- Additional comment from mminar7@gmail.com on 2008-04-08 07:49 EST --
I have similar problem. 
I added virtualization software Xen on Fedora 8 (x86-64).  I built HW RAID 1 on
two SATA disks where I installed Fedora 8 Linux on separate partition and swap.
Then I created another separate partition on that mirrored RAID with LVM2. Every
partition was mapped by device-mapper. 
There I put volume group and logical volume. This volume group was prepared for
Xen virtual guest disk partition. Everything was correct to this point.
I started Xen guest by ‘xm create’ without problem. I tried to connect by
vncviewer to guest vnc console and I saw looping same error message:

Init[1]: segfault at ………….. rip ………….. rsp ………… error 4 

I tried boot from CD image and I hope to see install menu for virtual guest, but
I saw only looping error message as I mentioned above.


-- Additional comment from bugzilla.redhat@sakher.fr on 2008-04-09 06:32 EST --
RAID is present - Intel ICH8R (Intel Matrix Storage Technology)
Thanks


-- Additional comment from mminar7@gmail.com on 2008-04-09 08:55 EST --
Thans, but my motherboard ASRock 4Core1333-Viiv has Southbridge: Intel® ICH8DH.
Northbridge: Intel® P965

-- Additional comment from ikent@redhat.com on 2008-04-15 12:45 EST --
Sorry to take so long to get back on this.
I suspect this is a problem I've worked on recently.
In any case I'll take it on and find out.

Ian


-- Additional comment from ikent@redhat.com on 2008-04-15 12:55 EST --
Any chance of someone obtaining a dump of their metadata please.

-- Additional comment from mminar7@gmail.com on 2008-04-16 11:17 EST --
I will try dump some data.

-- Additional comment from ikent@redhat.com on 2008-04-16 12:24 EST --
(In reply to comment #14)
> I will try dump some data.

Can you also try doing a "dmraid -ay <anyoldstringthatsnotaraidset>"
and let me know what happens please.

-- Additional comment from bugzilla.redhat@sakher.fr on 2008-04-26 03:11 EST --
Work fine with F9 and RedHat nash 6.0.47


-- Additional comment from ikent@redhat.com on 2008-04-27 02:01 EST --
(In reply to comment #16)
> Work fine with F9 and RedHat nash 6.0.47
> 

What controller?

-- Additional comment from bugzilla.redhat@sakher.fr on 2008-04-28 07:35 EST --
Intel ICH8R (Intel Matrix Storage Technology)(In reply to comment #17)
> (In reply to comment #16)
> > Work fine with F9 and RedHat nash 6.0.47
> > 
> 
> What controller?

Intel ICH8R (Intel Matrix Storage Technology)

-- Additional comment from ikent@redhat.com on 2008-04-28 08:32 EST --
(In reply to comment #18)
> Intel ICH8R (Intel Matrix Storage Technology)(In reply to comment #17)
> > (In reply to comment #16)
> > > Work fine with F9 and RedHat nash 6.0.47
> > > 
> > 
> > What controller?
> 
> Intel ICH8R (Intel Matrix Storage Technology)

OK, but you're seeing this on first-boot?
Ian



-- Additional comment from bugzilla.redhat@sakher.fr on 2008-04-29 12:57 EST --
(In reply to comment #19)
> (In reply to comment #18)
> > Intel ICH8R (Intel Matrix Storage Technology)(In reply to comment #17)
> > > (In reply to comment #16)
> > > > Work fine with F9 and RedHat nash 6.0.47
> > > > 
> > > 
> > > What controller?
> > 
> > Intel ICH8R (Intel Matrix Storage Technology)
> 
> OK, but you're seeing this on first-boot?
> Ian
> 
> 
No, i see that in specifications of my motherboard (Asus P5B-E Plus)
;)



-- Additional comment from ikent@redhat.com on 2008-04-30 02:45 EST --
(In reply to comment #20)
> (In reply to comment #19)
> > (In reply to comment #18)
> > > Intel ICH8R (Intel Matrix Storage Technology)(In reply to comment #17)
> > > > (In reply to comment #16)
> > > > > Work fine with F9 and RedHat nash 6.0.47
> > > > > 
> > > > 
> > > > What controller?
> > > 
> > > Intel ICH8R (Intel Matrix Storage Technology)
> > 
> > OK, but you're seeing this on first-boot?
> > Ian
> > 
> > 
> No, i see that in specifications of my motherboard (Asus P5B-E Plus)
> ;)
> 
> 

Ha, I think you misunderstood.
What I'm asking is if you see the SEGV problem at first boot
with this controller, but not at other times?

What I'm trying to understand is whether this is a problem
that we know about or a different one or if it is related to
specific configurations.

Ian


-- Additional comment from ardashev@bnl.gov on 2008-05-15 22:04 EST --
it is problem with dmraid not being properly started during first boot after
install. During install I see RAID fine. During 1st boot system cant find RAID.

errors are something about devmapper "coudln't parse string destination"

result is kernel hangs.


setup is intel dp35dp with ich9r raid and 3 disks on it as striped raid.

it works fine on FC7.
does not want to start up on FC9.

there are several bug reports similar to this, all pointing to dmraid.


if it helps:
on latest kernels in FC7 initrd file which is spplied with kernels was not
loading dmraid module and RAID was not visible after reboot. But system did
proceed w/o it since it is not root device. And I could do dmraid -ay and mount it.
So, I found on web that I could rebuild inird file with mkinird after I load
dmraid and it works again as usual, automatically mounting raid on reboot.

FC9 cant even start up, I am guessing inird is screwed up. But I don'tknow
enough how to fix it. 

-- Additional comment from bugzilla.redhat@sakher.fr on 2008-05-30 14:46 EST --
(In reply to comment #21)
> (In reply to comment #20)
> > (In reply to comment #19)
> > > (In reply to comment #18)
> > > > Intel ICH8R (Intel Matrix Storage Technology)(In reply to comment #17)
> > > > > (In reply to comment #16)
> > > > > > Work fine with F9 and RedHat nash 6.0.47
> > > > > > 
> > > > > 
> > > > > What controller?
> > > > 
> > > > Intel ICH8R (Intel Matrix Storage Technology)
> > > 
> > > OK, but you're seeing this on first-boot?
> > > Ian
> > > 
> > > 
> > No, i see that in specifications of my motherboard (Asus P5B-E Plus)
> > ;)
> > 
> > 
> 
> Ha, I think you misunderstood.
> What I'm asking is if you see the SEGV problem at first boot
> with this controller, but not at other times?
> 
> What I'm trying to understand is whether this is a problem
> that we know about or a different one or if it is related to
> specific configurations.
> 
> Ian
> 

Hi,

No, all times. With F9 final, don't work too :(
With F8.92 work fine


-- Additional comment from bugzilla.redhat@sakher.fr on 2008-06-18 16:08 EST --
Created an attachment (id=309784)
With dm create in init


-- Additional comment from bugzilla.redhat@sakher.fr on 2008-06-18 16:11 EST --
Created an attachment (id=309785)
With dm create in init


-- Additional comment from bugzilla.redhat@sakher.fr on 2008-06-18 16:19 EST --
(From update of attachment 309784 [details])
Without dm create in init


-- Additional comment from bugzilla.redhat@sakher.fr on 2008-07-01 19:18 EST --
HELP !!!!

Comment 1 Khamit Ardashev 2008-12-18 17:18:23 UTC
See  Bug 313411 for possible workaround.

Comment 2 Khamit Ardashev 2008-12-18 17:21:15 UTC
Would be nice to know if FC10 has this issue before trying upgrade, because eventually I would like to be able to put system disk on raid too.
Has anyone had this issue with FC10 ?


Note You need to log in before you can comment on or make changes to this bug.