Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454783 - bind-sdb - named exits with an assertion error.
Summary: bind-sdb - named exits with an assertion error.
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: bind
Version: 8
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Adam Tkac
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-09 23:42 UTC by Glen Eustace
Modified: 2013-04-30 23:40 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-09-10 06:42:22 UTC


Attachments (Terms of Use)
Core file after assertion error (deleted)
2008-08-04 21:15 UTC, Glen Eustace
no flags Details

Description Glen Eustace 2008-07-09 23:42:22 UTC
Description of problem:
named exits with assertion error.

Version-Release number of selected component (if applicable):
bind-sdb.9.5.0-27.rc1.fc8

How reproducible:
Everytime one tries to start the service

Steps to Reproduce:
1. service named start
2.
3.
  
Actual results:
Jul 10 11:17:58 agree-32 named-sdb[4311]: zone.c:2514: REQUIRE((((source) !=
((void *)0)) && (((const isc__magic_t *)(source))->magic == ((('Z') << 24 |
('O') << 16 | ('N') << 8 | ('E')))))) failed
Jul 10 11:17:58 agree-32 named-sdb[4311]: exiting (due to assertion failure)


Expected results:
It should not exit.

Additional info:
Previously running version bind-sdb-9.5.0-25.1.b2.fc8, does not have this issue.

Comment 1 Adam Tkac 2008-07-14 08:29:13 UTC
Would it be possible attach your named.conf, please? Thanks

Comment 2 Adam Tkac 2008-08-04 14:43:45 UTC
I tried reproduce this problem with your configuration and all versions works fine for me (I tried x86_64 binaries). Would it be possible reproduce bug again with latest version and then attach core file, please?

$ setenforce 0
$ chmod 775 /var/named
$ service named start

attach /var/named/core.* file

$ chmod 755 /var/named
$ setenforce 1

Thanks

Comment 3 Glen Eustace 2008-08-04 21:15:50 UTC
Created attachment 313404 [details]
Core file after assertion error

The assertion error occurs when a slave server requests an AXFR.  This works on an earlier release but that doesn't preclude my postgresql implementation to be faulty.

Comment 4 Adam Tkac 2008-08-05 11:57:19 UTC
Would it be possible try if proposed update works fine, please? Binary rpms are located on http://kojiweb.fedoraproject.org/koji/taskinfo?taskID=759467 (make sure you downloaded proper architecture). Thanks

Comment 5 Glen Eustace 2008-08-05 20:23:41 UTC
Installed 9.5.0-28.2.P1.fc8.i386 as requested, manually did an AXFR using dig and process did not die.  Will leave it running and see how it goes, looks good at this stage.

Comment 6 Fedora Update System 2008-08-06 10:35:32 UTC
bind-9.5.0-29.P2.fc8 has been submitted as an update for Fedora 8

Comment 7 Glen Eustace 2008-08-06 23:24:18 UTC
Having seen no re-occurence of the assertion error in over 24 hours, I would say that what ever you fixed has addressed the issue. Thanks.

Comment 8 Fedora Update System 2008-08-07 23:49:25 UTC
bind-9.5.0-29.P2.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bind'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-6992

Comment 9 Fedora Update System 2008-09-10 06:42:16 UTC
bind-9.5.0-29.P2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.