Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454761 - Refactor Entitlements and AccessRights
Summary: Refactor Entitlements and AccessRights
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: JBoss Customer Support Portal
Classification: Retired
Component: Integration-Red Hat
Version: 1.3.8
Hardware: All
OS: All
high
high
Target Milestone: ---
: ---
Assignee: JBoss CSP Bug Watch List
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-09 21:29 UTC by Mike Amburn
Modified: 2008-08-28 13:18 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-08-28 13:18:52 UTC
Type: ---


Attachments (Terms of Use)

Description Mike Amburn 2008-07-09 21:29:19 UTC
For example: AccessRights uses a categoryToProductMap, which has product id's hardcoded in it to put products into categories. Currently, adding a new product requires redeploying the application. The entitlements are all over the place now.

----
Data relocated from Jira (JBNET-1801)

Comment 1 John Sanda 2008-08-28 01:34:09 UTC
This bug should be closed. The part pertaining to AccessRights.java is covered by bug 45472. A separate bug should be created for entitlements refactoring. This does not provide enough information about it. I would have closed this bug myself, but I don't see the option to close it.

Comment 2 John Sanda 2008-08-28 13:18:39 UTC
That bug for AccessRights.java should have been bug 454726.

Comment 3 John Sanda 2008-08-28 13:18:52 UTC

*** This bug has been marked as a duplicate of bug 454726 ***


Note You need to log in before you can comment on or make changes to this bug.