Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454757 - "Saving repository failed." message in Software Repsotitory is not obvious or helpful
Summary: "Saving repository failed." message in Software Repsotitory is not obvious or...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: JBoss Customer Support Portal
Classification: Retired
Component: Product Mappings
Version: 1.3.8
Hardware: All
OS: All
low
low
Target Milestone: ---
: ---
Assignee: JBoss CSP Bug Watch List
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-09 21:28 UTC by Mike Amburn
Modified: 2011-01-31 17:47 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-01-31 17:39:26 UTC
Type: ---


Attachments (Terms of Use)

Description Mike Amburn 2008-07-09 21:28:22 UTC
I created a software repository object succesfully, then later I went back to edit it and and the detailed "file information". However, when I clicked the [save] button, it appeared as though the page had just reloaded without doing anything. The page focus was still near the [save] button.

I then scrolled up to the top of the page and there's a small error message written in the same text as the rest of the page that states "Saving repository failed." with no indication as to what the problem is. So I have no idea if its a problem that I can fix (text field is incorrect or missing) or if its a more serious problem.

I recommend that the error text be more obvious (say, in a box with a colored background) and more information about the problem be listed along side it. Also, the focus of the page should return to the top of the page, rather than remain at the bottom near the [save] button.

----
Data relocated from Jira (JBNET-1839)

Comment 1 John Sanda 2008-09-03 14:13:42 UTC
Mike,

Can you provide steps to reproduce? Thanks.

Comment 2 Frank Merenda 2008-09-03 14:30:57 UTC
Choose new software
don't fill in any fields except title
make "title" extremely long, like:

adfadfadsdassafsd adfadfadsdassafsd adfadfadsdassafsd adfadfadsdassafsd adfadfadsdassafsd adfadfadsdassafsd adfadfadsdassafsd adfadfadsdassafsd adfadfadsdassafsd adfadfadsdassafsd adfadfadsdassafsd adfadfadsdassafsd adfadfadsdassafsd adfadfadsdassafsd adfadfadsdassafsd adfadfadsdassafsd adfadfadsdassafsd adfadfadsdassafsd adfadfadsdassafsd adfadfadsdassafsd adfadfadsdassafsd adfadfadsdassafsd adfadfadsdassafsd adfadfadsdassafsd adfadfadsdassafsd adfadfadsdassafsd adfadfadsdassafsd adfadfadsdassafsd adfadfadsdassafsd adfadfadsdassafsd adfadfadsdassafsd adfadfadsdassafsd adfadfadsdassafsd adfadfadsdassafsd adfadfadsdassafsd adfadfadsdassafsd adfadfadsdassafsd adfadfadsdassafsd adfadfadsdassafsd adfadfadsdassafsd adfadfadsdassafsd adfadfadsdassafsd adfadfadsdassafsd adfadfadsdassafsd adfadfadsdassafsd adfadfadsdassafsd adfadfadsdassafsd adfadfadsdassafsd adfadfadsdassafsd adfadfadsdassafsd adfadfadsdassafsd adfadfadsdassafsd 

hit submit.
Look at the top of the page, and see the message "Save Failed".

Comment 4 David Spalding 2011-01-31 17:39:26 UTC
Bugs are no longer tracked under this classification. CSP is now monitored in 
Other | Customer Portal | Integrated app: JBoss CSP. 

Please refile any current defect records or RFEs under the current 
classification.

Comment 5 David Spalding 2011-01-31 17:47:28 UTC
Bugs are no longer tracked under this classification. CSP is now monitored in 
Other | Customer Portal | Integrated app: JBoss CSP. 

Please refile any current defect records or RFEs under the current 
classification.


Note You need to log in before you can comment on or make changes to this bug.