Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454756 - (RFE) "Products" field should list the actual software name as well as the SOFT-xxx ID on the Software Repository page
Summary: (RFE) "Products" field should list the actual software name as well as the SO...
Keywords:
Status: CLOSED DUPLICATE of bug 454545
Alias: None
Product: JBoss Customer Support Portal
Classification: Retired
Component: Product Mappings
Version: 1.3.8
Hardware: All
OS: All
medium
medium
Target Milestone: ---
: ---
Assignee: JBoss CSP Bug Watch List
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-09 21:27 UTC by Mike Amburn
Modified: 2008-09-03 19:44 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-09-03 19:44:52 UTC
Type: ---


Attachments (Terms of Use)

Description Mike Amburn 2008-07-09 21:27:55 UTC
This is regarding both the "New" software repository page (http://cspserver2.app.dev.redhat.com:8080/support-portal/restricted/software/repositoryDetails.html)
and viewing an existing software repository item (http://cspserver2.app.dev.redhat.com:8080/support-portal/restricted/software/repositoryDetails.html?id=462)

The "Products" field should list the actual name of the software product that this repository item belongs to, having only the "SOFT-xxx" id listed was because Salesforce didn't let have a Foreign-key type relationship between the repository item and the products, so we were forced to make our own keys with the SOFT-xxx id.

By having the actual product name listed, we can see that "JBoss-4.0.2.CP03" can be applied to JBoss 4.0.2 GA, JBoss 4.0.2 CP01, and JBoss 4.0.2 CP02... not just "SOFT-0122, SOFT-0162, and SOFT-0189"

----
Data relocated from Jira (JBNET-1843)

Comment 1 John Sanda 2008-09-03 19:44:52 UTC

*** This bug has been marked as a duplicate of bug 454545 ***


Note You need to log in before you can comment on or make changes to this bug.