Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454733 - Persistent classes do not implement equals() and hashCode()
Summary: Persistent classes do not implement equals() and hashCode()
Keywords:
Status: CLOSED DUPLICATE of bug 453183
Alias: None
Product: JBoss Customer Support Portal
Classification: Retired
Component: Other
Version: 1.3.8
Hardware: All
OS: All
medium
medium
Target Milestone: ---
: ---
Assignee: JBoss CSP Bug Watch List
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-09 21:15 UTC by Mike Amburn
Modified: 2008-08-28 12:55 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-08-28 12:55:00 UTC
Type: ---


Attachments (Terms of Use)

Description Mike Amburn 2008-07-09 21:15:08 UTC
Most of our persistent classes (i.e., classes managed by Hibernate) do not implement equals() and hashCode(). These methods are almost always critical for entity types as well as as any class in which instances are stored in a Collection. Documentation on this can be found in the Hibernate reference manual at http://www.hibernate.org/hib_docs/reference/en/html/persistent-classes.html. This article on the Hibernate site, http://www.hibernate.org/109.html also provides some good information.

Frank, I have been working on some test utility code that will be useful for testing equals() and hashCode() as well as other Hibernate code; so, I do not mind assigning this to myself.

----
Data relocated from Jira (JBNET-2161)

Comment 1 John Sanda 2008-08-28 01:54:43 UTC
Please close this bug. It is a duplicate of bug 453183.

Comment 2 Frank Merenda 2008-08-28 12:55:00 UTC

*** This bug has been marked as a duplicate of bug 453183 ***


Note You need to log in before you can comment on or make changes to this bug.