Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454717 - (RFE) Service Breach Time Notification Changes
Summary: (RFE) Service Breach Time Notification Changes
Keywords:
Status: CLOSED DUPLICATE of bug 454551
Alias: None
Product: JBoss Customer Support Portal
Classification: Retired
Component: Gatekeeper
Version: 1.3.8
Hardware: All
OS: All
high
medium
Target Milestone: ---
: ---
Assignee: JBoss CSP Bug Watch List
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 457070
TreeView+ depends on / blocked
 
Reported: 2008-07-09 20:58 UTC by Mike Amburn
Modified: 2008-08-28 13:06 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-08-28 13:06:17 UTC
Type: ---


Attachments (Terms of Use)

Description Mike Amburn 2008-07-09 20:58:36 UTC
Service Breach Time notifications
There are four situations when SBT notifications should be sent to JBoss Support.
case status is NEW and Threshold Time is reached (initial SLA)
case status is NEW and Breach Time is reached
case status is WORH and Threshold Time is reached (this would be a subsequent/followup SLA)
case status is WORH and Breach Time is reached (this would be a subsequent/followup SLA)

Service Breach Time notifications
These four situations need to be managed by four different rules in GateKeeper because we need the ability to turn on or off these four rules independently from each other.

Values of Threshold time according to Initial Response Time
Initial Response Time Threshold Time
1 hour 40 minutes before Breach
2 hours 40 minutes before Breach
4 hours 1 hour before Breach
4 business hours 1 hour before Breach
24 hours 4 hours before Breach
1 business day 4 hours before Breach
2 business days 12 hours before Breach
*These values should be configurable in a simple configurable file or table, so that we can easily change Warning Threshold Times in the future

Value of the Subject field in the email template

The template is the same for the 4 situations mentioned above, EXCEPT for the Subject of the email
Case status is NEW and Threshold Time is reached
Subject: [I-T group]-[tid] : NEW Case - IMPENDING SLA BREACH - [case summary]

Case status is NEW and Breach Time is reached
Subject: [I-T group]-[tid] : NEW Case - BREACHED SLA - [case summary]

Case status is WORH and Threshold Time is reached
Subject: [I-T group]-[tid] : WORH Case - IMPENDING SLA BREACH - [case summary]

Case status is WORH and Breach Time is reached
Subject: [I-T group]-[tid] : WORH Case - BREACHED SLA - [case summary]

Email template
-------------------------------------------------------------
From: no-reply@redhat.com
To: [I-T user's email address]
Subject: [Depends on specific case situation - See section above]

Body:

Case Url: [link to case]

Case Number: [tid]
Severity: [case severity]
Service Breach Time: [Service Breach Time]
Contact Name: [name of person who opened the case]
Case Company: [company name]
Contact Phone: [contact phone of person who opened case]
Customer Email: [email address of person who opened case]

Case assigned to: [name of the support team case owner and, if not = 'not assigned yet' ]

Product Selected: [product]
Version Selected: [version]
Module Selected: [module]


Case Summary: [case summary]

Case Description: [Full case description] 
----
Data relocated from Jira (JBNET-2239)

Comment 1 Nathan Lugert 2008-08-28 13:06:17 UTC

*** This bug has been marked as a duplicate of bug 454551 ***


Note You need to log in before you can comment on or make changes to this bug.