Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454712 - pulseaudio daemon crashes when enabling bluetooth audio device
Summary: pulseaudio daemon crashes when enabling bluetooth audio device
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: pulseaudio
Version: 9
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-09 20:49 UTC by Carl Roth
Modified: 2008-09-09 19:59 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-09-09 19:59:47 UTC


Attachments (Terms of Use)
gdb session trace from pulseaudio (deleted)
2008-07-09 20:52 UTC, Carl Roth
no flags Details

Description Carl Roth 2008-07-09 20:49:35 UTC
Description of problem:

I was trying to figure out a workaround to BUG454672, where I have a
multi-device pulseaudio setup with not all devices active at the same time...  I
was playing around with pacmd, seeing if I could interactively load pulseaudio
modules.

With my setup, if I enable a bluetooth audio device at startup (in default.pa or
thereabouts) then the device works correctly.

If I start up pulseaudio without the BT device defined, but then go in with
pacmd and try to load the bluetooth support, it crashes pulseaudio.

With all of the devices defined, here is a snippet from my default.pa:

  load-module module-alsa-sink device=intelHDA sink_name=Spkr rate=192000
  set-default-sink Spkr

  .nofail
  load-module module-alsa-sink device=plantronicsUSB sink_name=HeadPh rate=44100
  set-default-sink HeadPh
  .fail

  .nofail
  load-module module-alsa-sink device=bluetooth sink_name=bluetooth rate=44100
  set-default-sink bluetooth
  .fail

This configuration works (as long as the BT device is powered on, of course --
if the BT is powered off then pulseaudio stalls for a long while and also
sometimes fails to start at all)

If I comment out the last section and feed it line-by-line to a running
pulseaudio daemon using 'pacmd', the daemon crashes on the 'load-module' line.

Version-Release number of selected component (if applicable):

pulseaudio-0.9.10-1.fc9.x86_64
bluez-utils-3.35-2.fc9.x86_64
alsa-lib-1.0.16-3.fc9.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Carl Roth 2008-07-09 20:52:33 UTC
Created attachment 311418 [details]
gdb session trace from pulseaudio

Comment 2 Carl Roth 2008-07-09 20:53:47 UTC
I attached a sample gdb session from the pulseaudio failure to see if it would
reveal anything.  Note from the trace that 1) many of the stack parameters are
redacted ("value optimized out") and 1) gdb eventually fails with an internal
error.  Ouch.


Comment 3 Lennart Poettering 2008-09-09 19:57:10 UTC
This seems to be a bug in the BT module for ALSA, not in PA. It is known to be buggy. We now have patches that link PA directly to BlueZ, which will avoid this mess. 

I will close this bug now, since it is not a PA bug. Please try the bluezified PA when we have this in rawhide.


Note You need to log in before you can comment on or make changes to this bug.