Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454707 - iwl4965 doesn't works unde rhel5.2 x86_64
Summary: iwl4965 doesn't works unde rhel5.2 x86_64
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: iwl4965-firmware
Version: 5.2
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: John W. Linville
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-09 20:20 UTC by Carlos Lopez
Modified: 2008-07-14 17:22 UTC (History)
0 users

Fixed In Version: iwl4965-firmware-4.44.1.18-2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-10 13:26:15 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshoot (deleted)
2008-07-11 14:54 UTC, Carlos Lopez
no flags Details

Description Carlos Lopez 2008-07-09 20:20:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9) Gecko/2008061517 Red Hat/3.0-2.el5 Firefox/3.0

Description of problem:
When i try to load iwl4965 driver using modprobe doesn't works. I have verified that it isn't blacklisted under /etc/modprobe.d like in rhel5.0.

Version-Release number of selected component (if applicable):
iwl4965-firmware-4.44.17-1.noarch and kernel-2.6.18-92.1.6.el5.x86_64

How reproducible:
Always


Steps to Reproduce:
1.modprobe iwl4965
2.insert "alias wlan0 iwl4965" in modprobe.conf
3.

Actual Results:
Doesn't works and returns this error:

iwl4965: Intel(R) Wireless WiFi Link 4965AGN driver for Linux, 1.2.22ks
iwl4965: Copyright(c) 2003-2007 Intel Corporation
iwl4965: Detected Intel Wireless WiFi Link 4965AGN
iwl4965: iwlwifi-4965-1.ucode firmware file req failed: Reason -2
iwl4965: Could not read microcode: -2
iwl4965: probe of 0000:03:00.0 failed with error -2

Expected Results:
working wifi

Additional info:

Comment 1 Carlos Lopez 2008-07-09 20:30:05 UTC
As a Sam Sharpe says on rhel5-list:
https://www.redhat.com/archives/rhelv5-list/2008-July/msg00119.html, bug is
solved doing a soflink like this:

ln -s /lib/firmware/iwlwifi-4965.ucode /lib/firmware/iwlwifi-4965-1.ucode


 Can this be fixed in a next release of iwl4965-firmware package??

 Thanks.

Comment 2 John W. Linville 2008-07-10 13:26:15 UTC
There alread is a next release of the firmware package.  Please update it from 
the Supplementary CD.

Comment 3 Carlos Lopez 2008-07-10 20:26:10 UTC
Sorry John, but under supplementary channel anly appears same buggy package ...

Comment 5 John W. Linville 2008-07-11 12:49:40 UTC
Others seems to have been able to get it.  What are you doing to attempt the update?

Comment 6 Carlos Lopez 2008-07-11 14:25:23 UTC
I have tried now and I only see previous version ...

Comment 7 John W. Linville 2008-07-11 14:41:45 UTC
Could you be more specific about _what_ you are trying?

Comment 8 Carlos Lopez 2008-07-11 14:54:50 UTC
Created attachment 311590 [details]
Screenshoot

Comment 9 Carlos Lopez 2008-07-11 14:56:14 UTC
Yes, as you can see in this attachment, supplementary channel for rhel5 server
x86_64 only shows previous version: iwl4965-firmware-4.44.17-1.noarch

Comment 10 John W. Linville 2008-07-14 15:06:03 UTC
I am told that RHN has resolved the issue regarding availability of that 
package in the proper channel.  Please try the update process again!

Comment 11 Carlos Lopez 2008-07-14 17:22:19 UTC
Many thanks John. I have already downloaded new iwl-firmware package.


Note You need to log in before you can comment on or make changes to this bug.