Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454695 - plymouth sets lib incorrectly on ia64
Summary: plymouth sets lib incorrectly on ia64
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: plymouth
Version: rawhide
Hardware: ia64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: fedora-ia64
TreeView+ depends on / blocked
 
Reported: 2008-07-09 19:16 UTC by Doug Chapman
Modified: 2008-07-10 15:19 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-10 01:39:42 UTC


Attachments (Terms of Use)
patch to set lib correctly on ia64 (deleted)
2008-07-09 19:16 UTC, Doug Chapman
no flags Details | Diff
updated patch for setting lib dir correctly on ia64 (deleted)
2008-07-09 19:35 UTC, Doug Chapman
no flags Details | Diff

Description Doug Chapman 2008-07-09 19:16:46 UTC
Description of problem:
plymouth uses this line to set the library directory:

[ -z "$LIB" ] && $(eu-readelf -h /usr/bin/plymouth | grep Class | grep -q ELF64)
&& LIB="lib64" || LIB="lib"


however on ia64 does not have both /usr/lib64 and /usr/lib like x86_64 does, the
libs are all under /usr/lib (since we don't have 2 versions).

So, plymouth fails when mkinitrd runs it with:
/usr/libexec/plymouth/plymouth-populate-initrd: line 87: cd: /usr/lib64: No such
file or directory
install: cannot stat `/usr/lib64/plymouth/text.so': No such file or directory


suggested patch is attached


We do have a workaround of just removing the plymouth package so it does not get
used.

Version-Release number of selected component (if applicable):
plymouth-0.5.0-3.fc9

How reproducible:
100%

Steps to Reproduce:
1. on ia64 with the mkinitrd from fc10 (which uses plymouth)
2. make sure plymouth is installed
3. yum install kernel
  
Actual results:
Transaction Test Succeeded
Running Transaction
  Installing     : kernel                                            [1/1] 
/usr/libexec/plymouth/plymouth-populate-initrd: line 87: cd: /usr/lib64: No such
file or directory
install: cannot stat `/usr/lib64/plymouth/text.so': No such file or directory

system is then unbootable


Expected results:


Additional info:

Comment 1 Doug Chapman 2008-07-09 19:16:46 UTC
Created attachment 311406 [details]
patch to set lib correctly on ia64

Comment 2 Doug Chapman 2008-07-09 19:35:55 UTC
Created attachment 311409 [details]
updated patch for setting lib dir correctly on ia64

Oops, found a second place in plymouth with the same bit of code.  This patch
fixes both places I found it trying to use /usr/lib64 on ia64.

Comment 3 Ray Strode [halfline] 2008-07-10 01:39:42 UTC
If possible, i'd like to limit special casing for this sort of thing.

I commited this patch:

http://cvs.fedoraproject.org/viewcvs/rpms/plymouth/devel/find-right-libdir.patch?rev=1.1

Should be in tomorrows rawhide.  If not, please reopen.

Comment 4 Doug Chapman 2008-07-10 15:19:05 UTC
Ray,

MUCH better way of solving the problem.  I wasn't too thrilled about my fix either.

thanks for the quick resolution on this.

- Doug



Note You need to log in before you can comment on or make changes to this bug.