Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454636 - kdm cannot start default (Gnome) session when .xsession file exists
Summary: kdm cannot start default (Gnome) session when .xsession file exists
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kdebase-workspace
Version: 9
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-09 14:38 UTC by Michael Stefaniuc
Modified: 2008-07-09 16:33 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-09 16:33:01 UTC


Attachments (Terms of Use)

Description Michael Stefaniuc 2008-07-09 14:38:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008061517 Red Hat/3.0-2.el5 Firefox/3.0

Description of problem:
kdm cannot start the "Default" Gnome desktop when an even empty .xsession file exists. When "Gnome" instead of "Default" is selected in kdm as session type kdm will be able to start kdm.

Version-Release number of selected component (if applicable):
kdebase-workspace-4.0.5-3.fc9.i386

How reproducible:
Always


Steps to Reproduce:
1. touch $HOME/.xsession && chmod u+x $HOME/.xsession
2. Select "Default" (Gnome was the default) session type in kdm
3. Select "Gnome" session type in kdm as comparison

Actual Results:
The screen will go black and the kdm greeter will reaper (Steps to Reproduce: 2.)

Expected Results:
The Gnome desktop starts up (Steps to Reproduce: 3.)

Additional info:
than@redhat.com has seen a live demonstration of the bug.

Comment 1 Rex Dieter 2008-07-09 14:51:11 UTC
rpm -q xorg-x11-xinit-session

please

Comment 2 Rex Dieter 2008-07-09 14:52:09 UTC
My suspicion is that it is installed, and when it is, tries to use ~/.xsession,
and since it is empty, does nothing, and immediately ends the session.

Comment 3 Michael Stefaniuc 2008-07-09 15:44:49 UTC
Yeah, Than already debugged the problem and explained it to me as "user error":
Default for kdm means use .xsession if it exists else .xclients else Gnome else
KDE, etc. gdm doesn't have this "Default" notion.

Please feel free to close the ticket.


Note You need to log in before you can comment on or make changes to this bug.