Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454627 - virt-manager machine console loses focus with arrow key
Summary: virt-manager machine console loses focus with arrow key
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gtk-vnc
Version: 9
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
Assignee: Daniel Berrange
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-09 13:24 UTC by Tim Waugh
Modified: 2009-06-27 15:45 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-09-26 09:14:36 UTC


Attachments (Terms of Use)

Description Tim Waugh 2008-07-09 13:24:54 UTC
Description of problem:
The virtual machine console window does not fully grab keyboard input when the
mouse is over the vnc widget.  I have 'Grab keyboard input' set to 'On mouse over'.

Version-Release number of selected component (if applicable):
libvirt-0.4.4-1.fc9.x86_64
qemu-0.9.1-6.fc9.x86_64
gtk-vnc-python-0.3.6-1.fc9.x86_64
gtk-vnc-0.3.6-1.fc9.x86_64
gtk2-2.12.11-1.fc9.x86_64
gtk2-2.12.11-1.fc9.i386

How reproducible:
100%

Steps to Reproduce:
1.Double-click on activate virtual machine to see console.
2.Open a window on the virtual machine's console.  Keep mouse inside console.
3.Type into the window, anywhere, then press the 'Up' arrow key.
  
Actual results:
virt-manager's 'Shutdown' button now has focus.

Expected results:
Keyboard input still grabbed by vnc widget.

Additional info:
Worked fine until today.

Comment 1 Tim Waugh 2008-07-10 10:54:10 UTC
Downgrading gtk-vnc-python/gtk-vnc to 0.3.4-4.fc9 fixes it.

Comment 2 Daniel Berrange 2008-07-10 11:18:50 UTC
I believe this is caused by this changeset

changeset:   182:3b33ba158827
user:        Anthony Liguori <anthony@codemonkey.ws>
date:        Tue Mar 11 13:29:41 2008 -0500
files:       src/vncdisplay.c
description:
Propagate key press events.  This is needed for kvm-test.

This causes the key event to be forwarded onto the parent widget, and the
parent's parent & so on. Ultimately this gets processed by handler relating to
input focus, causing the shutdown button to get highlighted.


Comment 3 Daniel Berrange 2008-07-10 11:19:26 UTC
For reference

http://library.gnome.org/devel/gtk-tutorial/stable/x1812.html

Comment 4 Fedora Update System 2008-09-05 17:38:14 UTC
gtk-vnc-0.3.6-2.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/gtk-vnc-0.3.6-2.fc9

Comment 5 Torsten Rausche 2008-09-08 14:19:07 UTC
I just installed gtk-vnc-0.3.7-1.fc9.x86_64 from koji and can confirm that the focus doesn't switch to the console toolbar anymore when pressing the "tab" or "up" keys. BUT now the console window also doesn't release the mouse pointer when pressing "ctrl+alt"!

Comment 6 Fedora Update System 2008-09-11 17:06:42 UTC
gtk-vnc-0.3.7-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gtk-vnc'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-7907

Comment 7 Fedora Update System 2008-09-25 00:20:13 UTC
gtk-vnc-0.3.7-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Tim Waugh 2008-09-26 08:50:26 UTC
Comment #5 still applies to this:
> BUT now the console window also doesn't release the
> mouse pointer when pressing "ctrl+alt"!

This is a pretty critical FAIL.

Comment 9 Torsten Rausche 2008-09-26 09:07:08 UTC
(In reply to comment #8)
> Comment #5 still applies to this:
> > BUT now the console window also doesn't release the
> > mouse pointer when pressing "ctrl+alt"!
> 
> This is a pretty critical FAIL.

Yes, but it is fixed now. See bug 463729.

Comment 10 Daniel Berrange 2008-09-26 09:14:36 UTC
Please do *NOT* reopen bugs to report different problems. As Torsten says there is a separate bug tracking this problem & its resolution. It is completely unconnected to this existing bug.


Note You need to log in before you can comment on or make changes to this bug.