Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454624 - virt-manager in Rawhide fails to start
Summary: virt-manager in Rawhide fails to start
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 458520 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-09 13:10 UTC by Richard W.M. Jones
Modified: 2014-07-02 14:14 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-11-25 14:35:43 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1115503 None None None Never

Internal Links: 1115503

Description Richard W.M. Jones 2008-07-09 13:10:13 UTC
This is the error message recorded in /root/.virt-manager/virt-manager.log:

[Wed, 09 Jul 2008 14:09:10 virt-manager 332] ERROR (virt-manager:141) Traceback 
(most recent call last):
  File "/usr/share/virt-manager/virt-manager.py", line 310, in <module>
    main()
  File "/usr/share/virt-manager/virt-manager.py", line 260, in main
    config = vmmConfig(appname, appversion, gconf_dir, glade_dir, icon_dir, data
_dir)
  File "/usr/share/virt-manager/virtManager/config.py", line 50, in __init__
    gconf.CLIENT_PRELOAD_NONE)
GError: Failed to contact configuration server; some possible causes are that yo
u need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to
 a system crash. See http://www.gnome.org/projects/gconf/ for information. (Deta
ils -  1: Failed to get connection to session: dbus-launch failed to autolaunch 
D-Bus session: No protocol specified
Autolaunch error: X11 initialization failed.
)
None

Comment 1 Adam Huffman 2008-08-31 15:12:00 UTC
Seeing the same if I try to start virt-manager from the GNOME menu.  It does start from a terminal, though only an su - terminal.

Comment 2 Cole Robinson 2008-09-08 16:44:40 UTC
*** Bug 458520 has been marked as a duplicate of this bug. ***

Comment 3 Cole Robinson 2008-09-08 16:57:53 UTC
Hmm, I don't think this is virt-manager's fault. On a fully updated rawhide install:

----------------------------------------------------------------------
$ cat testscript.py 
import gconf

gconf_dir = "/apps/virt-manager"

conf = gconf.client_get_default()
conf.add_dir(gconf_dir, gconf.CLIENT_PRELOAD_NONE)

$ python testscript.py

$ su -c 'python testscript.py'
Password: 
Traceback (most recent call last):
  File "testscript.py", line 6, in <module>
    conf.add_dir(gconf_dir, gconf.CLIENT_PRELOAD_NONE)
glib.GError: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://www.gnome.org/projects/gconf/ for information. (Details -  1: Failed to get connection to session: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)

$ getenforce 0
Permissive
-------------------------------------------------------------------

So, not the exact same error, but the same spot and the same reproducer. This passes no problems on f9.

Also found a dbus thread from March which seems to talk about issues accessing session bus with root, but I'm not too dbus savvy:

http://lists.freedesktop.org/archives/dbus/2008-March/009458.html

Comment 4 James Laska 2008-09-09 14:34:32 UTC
crobinso: should this bug be reassigned to GConf, or dbus, noting the reproducer you've posted in comment#3?

Comment 5 Cole Robinson 2008-09-09 14:50:34 UTC
Actually there is a fix for this upstream now:

http://hg.et.redhat.com/virt/applications/virt-manager--devel?cs=ac6da22acd6a

I talked with rstrode about this yesterday. It isn't a gconf bug, it's an intended change: via dbus, root is now explicitly disallowed from accessing the user bus. 

virt-manager shouldn't have this issue because console-helper facilitates forcing root to use it's own bus, however we were losing some of the magic here since default virt-manager behavior is to fork into the background, which made the app lose the assistance.

The fix was just to move the gconf initialization to before the fork, and it all just works now.

Moving this bug to POST, we will be cutting a release soon so this will be in the beta.

Comment 6 Cole Robinson 2008-11-25 14:35:43 UTC
This is in F10/Rawhide. Closing.


Note You need to log in before you can comment on or make changes to this bug.