Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454623 - virt-viewer in Rawhide fails to start with lengthy gtk error and segfault
Summary: virt-viewer in Rawhide fails to start with lengthy gtk error and segfault
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-viewer
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Daniel Berrange
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-09 13:08 UTC by Richard W.M. Jones
Modified: 2008-08-08 15:03 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-08-08 15:03:01 UTC


Attachments (Terms of Use)

Description Richard W.M. Jones 2008-07-09 13:08:46 UTC
# virt-viewer 8

(virt-viewer:32664): Gtk-CRITICAL **: gtk_container_add_with_properties:
assertion `widget->parent == container' failed

(virt-viewer:32664): Gtk-CRITICAL **: gtk_container_add_with_properties:
assertion `widget->parent == container' failed

(virt-viewer:32664): Gtk-CRITICAL **: gtk_widget_realize: assertion
`GTK_WIDGET_ANCHORED (widget) || GTK_IS_INVISIBLE (widget)' failed

(virt-viewer:32664): Gdk-CRITICAL **: gdk_window_set_cursor: assertion
`GDK_IS_WINDOW (window)' failed

(virt-viewer:32664): Gdk-CRITICAL **: gdk_gc_new: assertion `drawable != NULL'
failed

(virt-viewer:32664): Gdk-CRITICAL **: gdk_drawable_get_visual: assertion
`GDK_IS_DRAWABLE (drawable)' failed

(virt-viewer:32664): Gdk-CRITICAL **: gdk_visual_get_screen: assertion
`GDK_IS_VISUAL (visual)' failed

(virt-viewer:32664): Gdk-CRITICAL **: _gdk_image_new_for_depth: assertion
`visual || depth != -1' failed
Segmentation fault

Comment 1 Daniel Berrange 2008-08-08 12:26:12 UTC
I can't reproduce this problem in today's rawhide - can you verify that its still a problem for you

Comment 2 Richard W.M. Jones 2008-08-08 15:03:01 UTC
Yeah, it's now working again in current Rawhide ==> CLOSING.


Note You need to log in before you can comment on or make changes to this bug.