Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454614 - Coredump in the g_type_check_instance_cast
Summary: Coredump in the g_type_check_instance_cast
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: nspluginwrapper
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-09 12:02 UTC by Zdenek Kabelac
Modified: 2008-08-04 12:51 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-08-04 12:51:05 UTC


Attachments (Terms of Use)

Description Zdenek Kabelac 2008-07-09 12:02:56 UTC
Description of problem:

I'm also seeing this kind of coredumps:

#0  0x449f1378 in IA__g_type_check_instance_cast (type_instance=<value optimized
out>, iface_type=<value optimized out>) at gtype.c:3723
3723	      if (type_instance->g_class)
Missing separate debuginfos, use: debuginfo-install alsa-lib.i386 atk.i386
cairo.i386 expat.i386 fontconfig.i386 freetype.i386 gcc.i386 glibc.i686
libICE.i386 libSM.i386 libXau.i386 libXcomposite.i386 libXcursor.i386
libXdmcp.i386 libXext.i386 libXfixes.i386 libXi.i386 libXrandr.i386
libXrender.i386 libXt.i386 libpng.i386 libselinux.i386 libxcb.i386 nspr.i386
pango.i386 pixman.i386 zlib.i386
(gdb) bt
#0  0x449f1378 in IA__g_type_check_instance_cast (type_instance=<value optimized
out>, iface_type=<value optimized out>) at gtype.c:3723
#1  0xf77135ae in ?? () from /usr/lib/mozilla/plugins/libflashplayer.so
#2  0xf77e9cd1 in ?? () from /usr/lib/mozilla/plugins/libflashplayer.so
#3  0xf7b72007 in ?? () from /usr/lib/mozilla/plugins/libflashplayer.so
#4  0xf7b72155 in ?? () from /usr/lib/mozilla/plugins/libflashplayer.so
#5  0xf771363d in ?? () from /usr/lib/mozilla/plugins/libflashplayer.so
#6  0xf7b7d19f in ?? () from /usr/lib/mozilla/plugins/libflashplayer.so
#7  0xf77eff0b in ?? () from /usr/lib/mozilla/plugins/libflashplayer.so
#8  0xf77130fe in ?? () from /usr/lib/mozilla/plugins/libflashplayer.so
#9  0x448fe936 in g_timeout_dispatch (source=Could not find the frame base for
"g_timeout_dispatch".
) at gmain.c:3527
#10 0x448fe211 in g_main_dispatch () at gmain.c:2068
#11 IA__g_main_context_dispatch (context=<value optimized out>) at gmain.c:2620
#12 0x449018b3 in g_main_context_iterate (context=<value optimized out>,
block=<value optimized out>, dispatch=<value optimized out>, self=Could not find
the frame base for "g_main_context_iterate".
) at gmain.c:2701
#13 0x44901dd2 in IA__g_main_loop_run (loop=<value optimized out>) at gmain.c:2924
#14 0x44f900e5 in IA__gtk_main () at gtkmain.c:1172
#15 0x080507f1 in do_main (argv=0xfffa8124, argc=1) at ../src/npw-viewer.c:3216
#16 main (argc=1, argv=0xfffa8124) at ../src/npw-viewer.c:3371


This looks like failure from accessing incorrectly converted pointer from 32bit
to 64bit platform - however I've no idea how it works internaly in the
nspluginwrapper.

I do not see these frequent Flash crashes when running 32bit mozilla with the
exactly same libflashplugin.so.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Martin Stransky 2008-08-04 12:51:05 UTC
We are not going to fix bugs in flash player. Closing as WONTFIX.


Note You need to log in before you can comment on or make changes to this bug.