Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454611 - [man] Ctrl+] not documented for xenconsole
Summary: [man] Ctrl+] not documented for xenconsole
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen
Version: 5.2
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Michal Novotny
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-09 11:50 UTC by Alexander Todorov
Modified: 2014-02-02 22:36 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-02 10:11:08 UTC


Attachments (Terms of Use)
XM Documentation update (deleted)
2009-03-16 09:28 UTC, Michal Novotny
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:1328 normal SHIPPED_LIVE xen bug fix and enhancement update 2009-09-01 10:32:30 UTC

Description Alexander Todorov 2008-07-09 11:50:54 UTC
Description of problem:
xenconsole does not accept Ctrl+C. There's no way to detach from the console if
the boot hangs.

Version-Release number of selected component (if applicable):
xen-3.0.3-64.el5

How reproducible:
Always

Steps to Reproduce:
1. Boot Fedora9 pv guest
2. Attach to the guests console
3. Type Ctrl+C
  
Actual results:
console does not detach 

Expected results:
console accepts ctrl+c and detaches

Additional info:
the guest is not configured to send it's output to the console and we can see
only some early boot messages.

Comment 1 Daniel Berrange 2008-07-09 11:54:11 UTC
The interrupt key matches telnet -  Ctrl + ]  - because you need to be able to
send Ctrl+C to processes in the guest without it interrupting the console



Comment 2 Alexander Todorov 2008-07-09 12:08:36 UTC
Ahhh, tested and works perfect. However that's not documented in the manpage.
Changing summary to reflect that:

`man xm' is not listing Ctrl+] as sequence to terminate the console connection,
which is equivalent to Ctrl+C

A side note:
`man xenconsole' doesn't exist at all.

Please change to the right component used to track man pages updates.

Comment 3 RHEL Product and Program Management 2008-07-09 12:19:09 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 5 Michal Novotny 2009-03-16 09:28:20 UTC
Created attachment 335325 [details]
XM Documentation update

This is an update of xm documentation as returned by `man xm` to add information about interrupt key, Ctrl + ]. Also information about Ctrl+C does only send (forward) this key to the guest but doesn't interrupt (detach) console is also included...

Comment 6 Jiri Denemark 2009-03-20 13:52:03 UTC
Fix built into xen-3.0.3-83.el5

Comment 8 Gurhan Ozen 2009-07-16 21:06:19 UTC
       console domain-id
           Attach to domain domain-id’s console.  If you’ve set up your Domains to have a traditional log in console this will look much like a normal text log in screen. To detach from
           console use telnet style interrupt key, Ctrl + ]. Standard interrupt key (Ctrl+C) is used for sending this key to the guest machine without interrupting the console.

Comment 10 errata-xmlrpc 2009-09-02 10:11:08 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1328.html


Note You need to log in before you can comment on or make changes to this bug.