Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454602 - perl scripts do not sent LOG_EMERG log messages (Sys::Syslog)
Summary: perl scripts do not sent LOG_EMERG log messages (Sys::Syslog)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: perl
Version: 5.2
Hardware: All
OS: Linux
urgent
high
Target Milestone: rc
: ---
Assignee: Marcela Mašláňová
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
: 502445 (view as bug list)
Depends On:
Blocks: 956257 956263 956264
TreeView+ depends on / blocked
 
Reported: 2008-07-09 10:00 UTC by Issue Tracker
Modified: 2018-10-19 19:22 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 956257 (view as bug list)
Environment:
Last Closed: 2009-01-20 21:10:56 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:0117 normal SHIPPED_LIVE perl bug fix update 2009-01-20 16:04:48 UTC

Description Issue Tracker 2008-07-09 10:00:43 UTC
Escalated to Bugzilla from IssueTracker

Comment 3 Martin Poole 2008-07-09 10:03:05 UTC
Description of problem:

A set of scripts which sent LOG_EMERG log messages through Sys::Syslog perl
module on RHEL4.3, do not send the messages with this log level on RHEL5.1.

How reproducible:
RHEL5.1 system installed.

Steps to Reproduce:
Invoke the following command from the console:
$ perl -e 'use Sys::Syslog; syslog(LOG_EMERG, "Test message")'

Actual results:
syslog: invalid level/facility: LOG_EMERG at -e line 1

Expected results:
Message from syslogd@test1 at Fri Nov  7 11:28:34 2008 ...
test1 host1: Test message

Additional info:
The current version of the module Sys::Syslog in RHEL5 is 0.13. This issue was
fixed in 0.14:

The lines of code:

if ($_ eq 'kern' || $num <= 0) {
    croak "syslog: invalid level/facility: $_"

were changed to

if ($num < 0) {
   croak "syslog: invalid level/facility: $word"


It looks like the upstream bug is:

https://rt.cpan.org/Public/Bug/Display.html?id=17518



Comment 5 RHEL Product and Program Management 2008-07-09 10:14:05 UTC
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.

Comment 16 errata-xmlrpc 2009-01-20 21:10:56 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0117.html

Comment 18 Marcela Mašláňová 2009-05-25 13:58:52 UTC
*** Bug 502445 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.