Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454598 - evdev is lacking emulatewheel support for mouse
Summary: evdev is lacking emulatewheel support for mouse
Keywords:
Status: CLOSED DUPLICATE of bug 446627
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-evdev
Version: 9
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Peter Hutterer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-09 09:11 UTC by Dag
Modified: 2008-07-14 07:46 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-14 07:46:52 UTC


Attachments (Terms of Use)

Description Dag 2008-07-09 09:11:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008061712 Fedora/3.0-1.fc9 Firefox/3.0

Description of problem:
when evdev is used as mouse driver you can't use the emulatewheel option because it's not implemented.

Version-Release number of selected component (if applicable):
xorg-x11-drv-evdev-2.0.1-1.fc9.i386

How reproducible:
Always


Steps to Reproduce:
1. add an xorg.conf section for your mouse precising you want to use the "mouse" driver and the emulatewheel option
2. restart your xorg server (or the computer)


Actual Results:
the emulatewheel option was noit taken into acount.
the "mouse" driver was not used for the mouse.
the "evdev" driver was used for the mouse.

Expected Results:
first of all the "mouse" driver should have been used instead of "evdev" as precised in the xorg.conf input section.

secondly the "evdev" driver should support the Emulatewheel option to be able toreplace completely the old "mouse" driver.

Additional info:
here is what I added to my xorg.conf to enable the emulatewheel option:

Section "ServerFlags"
        Option "NoAutoAddDevices"
EndSection

then add an input section with the driver "mouse":
Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Device" "/dev/input/mice"
        Option      "Protocol" "explorerPS/2"
        Option      "Buttons"   "5"
        Option      "EmulateInertia" "50"
        Option          "Emulate3Buttons" "on"
        Option          "Emulate3Timeout" "50"
        Option          "EmulateWheel" "on"
        Option          "EmulateWheelTimeout" "200"
        Option          "EmulateWheelButton" "2"
        Option          "XAxisMapping"  "6 7"
        Option          "YAxisMapping"  "4 5"
        Option          "ZAxisMapping" "4 5"
EndSection

and add this input device to your serverlayout section.
Then add any of your devices because it won't be autodetected anymore.

I first reported this bug as a mouse driver issue here:
https://bugzilla.redhat.com/show_bug.cgi?id=446627

Comment 1 Peter Hutterer 2008-07-14 07:46:52 UTC
Closing as duplicate so we only have one history of this bug.

*** This bug has been marked as a duplicate of 446627 ***


Note You need to log in before you can comment on or make changes to this bug.