Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454591 - HTTP 401 responses lack Content-Length headers
Summary: HTTP 401 responses lack Content-Length headers
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: tog-pegasus
Version: 5.3
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Vitezslav Crhonek
QA Contact:
URL:
Whiteboard: SanityOnly
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-09 06:55 UTC by Tim Potter
Modified: 2009-06-20 04:47 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-20 22:19:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:0250 normal SHIPPED_LIVE tog-pegasus bug fix and enhancement update 2009-01-20 16:06:52 UTC

Description Tim Potter 2008-07-09 06:55:08 UTC
Description of problem:

From OpenPegasus bugzilla 7202 at:

http://cvs.opengroup.org/bugzilla/show_bug.cgi?7202

"HTTP 401 (unauthorized) responses don't include Content-Length headers.  A
"Content-Length: 0" header should be present according to section 4.4 of RFC 2616.  

Since the HTTP server doesn't close the connection after sending a 401 with an
authentication challenge, a client doesn't know when to stop reading before
sending the challenge response."

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 RHEL Product and Program Management 2008-09-10 11:27:09 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 4 Chris Ward 2008-11-28 07:14:53 UTC
Partners, this bug should be fixed in the latest RHEL 5.3 Snapshot. We believe that you have some interest in its correct functionality, so we're making a friendly request to send us some testing feedback. 

If you have a chance to test it, please share with us your findings. If you have successfully VERIFIED the fix, please add PartnerVerified to the Bugzilla keywords, along with a description of the results. Thanks!

Comment 5 Miroslav Vadkerti 2008-12-12 13:01:23 UTC
Verified from partners, adding OtherQA and SanityOnly, as I couldn't test this bug.

Comment 7 errata-xmlrpc 2009-01-20 22:19:13 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0250.html


Note You need to log in before you can comment on or make changes to this bug.