Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454586 - Please backport ProxyPassMatch to RHEL5 httpd
Summary: Please backport ProxyPassMatch to RHEL5 httpd
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: httpd
Version: 5.2
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Joe Orton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-09 05:33 UTC by Binand Sethumadhavan
Modified: 2008-07-09 08:43 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-09 08:43:49 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Binand Sethumadhavan 2008-07-09 05:33:58 UTC
Description of problem:
ProxyPassMatch directive is implemented in Apache 2.2.5. Please see if it is
possible to backport this directive to RHEL5's 2.2.3 Apache.

Version-Release number of selected component (if applicable):

httpd-2.2.3-11.el5_1.3

How reproducible:

Always

Steps to Reproduce:
1. Edit httpd.conf to include a ProxyPassMatch directive (eg: ProxyPassMatch
^(/.*\.jsp)$ ajp://localhost:8009$1)
2. Reload httpd (sevice httpd reload)
3. Error logged.
  
Actual results:

Syntax error on line 25 of /etc/httpd/conf.d/proxy_ajp.conf:
Invalid command 'ProxyPassMatch', perhaps misspelled or defined by a module not
included in the server configuration

Expected results:

Normal reload of Apache

Additional info:

The configuration directive is needed for connecting Apache to Tomcat. There is
a workaround using mod_rewrite rules, though (but that requires a different
module to be loaded into Apache)

Comment 1 Joe Orton 2008-07-09 08:43:49 UTC
Thanks for the report.  Yes, this is already proposed for inclusion in 5.3.

*** This bug has been marked as a duplicate of 449159 ***


Note You need to log in before you can comment on or make changes to this bug.