Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454584 - boot.iso should not need to download stage2.img?
Summary: boot.iso should not need to download stage2.img?
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 10
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-09 05:01 UTC by Jens Petersen
Modified: 2009-02-16 20:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-02-16 20:32:20 UTC


Attachments (Terms of Use)

Description Jens Petersen 2008-07-09 05:01:46 UTC
Description of problem:
I understood that stage2.img is now included in boot.iso so the text installer
should not
need to download it before moving to stage2.

Version-Release number of selected component (if applicable):
anaconda-11.4.1.12-1

How reproducible:
every time

Steps to Reproduce:
1. boot boot.iso
2. text installer asks Installation Method
3. anaconda tries to load stage2.img
  
Actual results:
2. need to select URL or nfs and give source
3. anaconda is unable to load or mount image

Expected results:
2. installer to proceed to stage2
3. (image to mount)

Comment 1 Andy Lindeberg 2008-07-09 13:26:30 UTC
You'd think that. And yet....

I believe a fix is being worked on. In the meantime, passing
stage2=http://<yourserverofchoice>/pub/fedora/linux/development/<platformofchoice>/os/images/stage2.img
as an argument seems to be working.

Comment 2 Chris Lumens 2008-07-09 14:45:58 UTC
Peter fixed this.  We should have it in the next build of anaconda.

Comment 3 Bug Zapper 2008-11-26 02:31:45 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping


Note You need to log in before you can comment on or make changes to this bug.