Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454561 - Please rebuild against xulrunner-1.9-1
Summary: Please rebuild against xulrunner-1.9-1
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: yelp
Version: rawhide
Hardware: i386
OS: Linux
low
high
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-08 23:53 UTC by sangu
Modified: 2008-07-23 09:46 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-23 09:46:33 UTC


Attachments (Terms of Use)

Description sangu 2008-07-08 23:53:11 UTC
Description of problem:
Starting -> Segmentaion fault in yelp-2.22.1-2.fc10.
$gdb yelp
<skip>
Program received signal SIGSEGV, Segmentation fault.
0x01724dae in nsEmbedStream::AppendToStream (this=0x8344b30, 
    aData=0xbfffb208 "<html
xmlns=\"http://www.w3.org/1999/xhtml\"><head><title>�\215��\212��\201��\203\221</title><style
type=\"text/css\">\n        body {\n          margin: 0px;\n          padding:
0px;\n        }\n        h1 {\n          font-"..., aLen=5365) at
nsEmbedStream.cpp:199
199						aLen); /* len */
Current language:  auto; currently c++

(gdb) bt
#0  0x01724dae in nsEmbedStream::AppendToStream (this=0x8344b30, 
    aData=0xbfffb208 "<html
xmlns=\"http://www.w3.org/1999/xhtml\"><head><title>�\215��\212��\201��\203\221</title><style
type=\"text/css\">\n        body {\n          margin: 0px;\n          padding:
0px;\n        }\n        h1 {\n          font-"..., aLen=5365) at
nsEmbedStream.cpp:199
#1  0x01107382 in EmbedPrivate::AppendToStream (this=0x81c5f38, 
    aData=0xbfffb208 "<html
xmlns=\"http://www.w3.org/1999/xhtml\"><head><title>�\215��\212��\201��\203\221</title><style
type=\"text/css\">\n        body {\n          margin: 0px;\n          padding:
0px;\n        }\n        h1 {\n          font-"..., aLen=5365) at
EmbedPrivate.cpp:689
#2  0x080591d6 in window_write_html (data=0x814c450) at yelp-window.c:2743
#3  0x0805ae8d in page_request_cb (document=0x814b0c8, 
    signal=YELP_DOCUMENT_SIGNAL_PAGE, req_id=1, func_data=0x822b3b0, 
    window=0x8151060) at yelp-window.c:888
#4  0x08062b95 in request_idle_page (request=0x82fdec0) at yelp-document.c:674
#5  0x00d412b1 in g_idle_dispatch (source=0x8310a58, callback=0, 
    user_data=0x82fdec0) at gmain.c:4173
#6  0x00d43211 in g_main_dispatch () at gmain.c:2068
#7  IA__g_main_context_dispatch (context=0x80afdf8) at gmain.c:2620
#8  0x00d468b3 in g_main_context_iterate (context=0x80afdf8, block=1, 
    dispatch=1, self=0x80864b8) at gmain.c:2701
#9  0x00d46dd2 in IA__g_main_loop_run (loop=0x82e4830) at gmain.c:2924
#10 0x005410e5 in IA__gtk_main () at gtkmain.c:1172
---Type <return> to continue, or q <return> to quit---
#11 0x0805ea53 in main_start () at yelp-main.c:121
#12 main (argc=Cannot access memory at address 0xe6b
) at yelp-main.c:415

Then, Installing yelp-2.22.1-3.fc9.i386 (F9 update), starting yelp works well.

Version-Release number of selected component (if applicable):
2.22.1-2.fc10

How reproducible:
always

Steps to Reproduce:
1. Launch yelp
2.
3.
  
Actual results:
Starting -> Segmentaion fault 

Expected results:


Additional info:

Comment 1 Matthew Barnes 2008-07-09 03:04:41 UTC
yelp-2.23.1-2.fc10 is the latest Rawhide package.  Try updating?

Comment 2 sangu 2008-07-09 03:33:52 UTC
comment #1)
> yelp-2.23.1-2.fc10 is the latest Rawhide package.  Try updating?

http://koji.fedoraproject.org/koji/buildinfo?buildID=53377 : Building
yelp-2.23.1-2.fc10 failed.

yelp version is 2.22.1-2.fc10 in current rawhide.

http://download.fedora.redhat.com/pub/fedora/linux/development/i386/os/Packages/yelp-2.22.1-2.fc10.i386.rpm(In
reply to 


Comment 3 Matthew Barnes 2008-07-10 13:32:47 UTC
Looks like the build is dying in XULRunner right off the bat:

In file included from /usr/include/xulrunner-sdk-1.9/stable/nsXPCOMStrings.h:42
,
                 from /usr/include/xulrunner-sdk-1.9/stable/nsStringAPI.h:53
,
                 from Yelper.cpp:28
:
/usr/include/xulrunner-sdk-1.9/stable/nscore.h:51:21:
 
error: 
prtypes.h: No such file or directory


Reassigning this to Martin Stransky.  Martin, can you look into this?

Comment 4 Martin Stransky 2008-07-10 13:57:57 UTC
The xulrunner package there seems to be still broken. I'll check it.

Comment 5 Martin Stransky 2008-07-23 09:46:33 UTC
Should be fixed in yelp-2.23.1-3.fc10


Note You need to log in before you can comment on or make changes to this bug.