Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454473 - libdevmapper is segfaulting on reboot
Summary: libdevmapper is segfaulting on reboot
Keywords:
Status: CLOSED DUPLICATE of bug 452799
Alias: None
Product: Fedora
Classification: Fedora
Component: lvm2
Version: rawhide
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: ---
Assignee: LVM and device-mapper development team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-08 18:09 UTC by Daniel Walsh
Modified: 2008-07-09 03:03 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-09 03:03:08 UTC


Attachments (Terms of Use)

Description Daniel Walsh 2008-07-08 18:09:43 UTC
Description of problem:

init[1]: segfault at 10 ip a4a584 sp 7fff4d6cce08 4 in
libdevmapper.so.1.0.2[a3c00+15000]

device-mapper-libs-1.02.27-3.fc10.x86_64

My machine is done for.

Comment 1 Daniel Walsh 2008-07-08 18:10:59 UTC
I am using an encrypted file system.


Comment 2 Will Woods 2008-07-08 18:30:18 UTC
Ouch. Doesn't seem to happen on non-crypted machines, at least. Attempting to
reproduce on i386.

Comment 3 Milan Broz 2008-07-08 18:54:42 UTC
Isn't it the same problem like bug 446669 ?

segfault if only secondary bug there, nash just doesn't activate proper device
and following command (in this case cryptsetup) see no physical device.

Comment 4 Will Woods 2008-07-08 19:15:27 UTC
I'm not getting a segfault, although my machines (x86_64 and i386) do say:
  Setting up disk encryption: /dev/sda2
  Command failed: Error opening key file: No such file or directory
And then fail to find VolGroup00.

Was this system upgraded from an earlier release, or is it a fresh install of
rawhide? Which rawhide version did you install?

Comment 5 Daniel Walsh 2008-07-08 19:55:32 UTC
This was a yum update,  Was installed for about a month.

Comment 6 Jeremy Katz 2008-07-09 03:03:08 UTC
Add rhgb back to your kernel command line

*** This bug has been marked as a duplicate of 452799 ***


Note You need to log in before you can comment on or make changes to this bug.