Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454444 - Crash dump against piruit occured after I selected option to review contents of Package Update
Summary: Crash dump against piruit occured after I selected option to review contents ...
Keywords:
Status: CLOSED DUPLICATE of bug 452538
Alias: None
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Channels
Version: RHN Devel
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Sebastian Skracic
QA Contact: Red Hat Network Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-08 15:17 UTC by Donald Holly
Modified: 2013-01-10 10:24 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-08-26 17:47:06 UTC


Attachments (Terms of Use)
rhel 5.2 crash dump against piruit (deleted)
2008-07-08 15:17 UTC, Donald Holly
no flags Details | Diff

Description Donald Holly 2008-07-08 15:17:03 UTC
Description of problem: Crash dump  occured after I selected option to review 
contents of Package Updater. Screen message states: "An unhandled exception has 
occurred. This is mostly a bug. Please save the crash dump and file a detailed 
bug report against pirut at https://bugzilla.redhat.com/bugzilla".


Version-Release number of selected component (if applicable): Red Hat EL 5.2


How reproducible: Everytime I select to review Package Updates.


Steps to Reproduce:
1. Icon notice that there are updates waiting to be processed.
2. Select option to review updates
3. Crash dump notice.
  
Actual results: Crash dump.


Expected results: To see packages that can be updated.


Additional info: Had updated twice before on a fresh installation of RHEL 5.2.

Comment 1 Donald Holly 2008-07-08 15:17:03 UTC
Created attachment 311277 [details]
rhel 5.2 crash dump against piruit

Comment 2 James Antill 2008-07-08 16:46:15 UTC
 Well we probably could handle this better, but it also shouldn't be happening
... the actual problem is that the metadata on the RHN satellite you are talking
to is bad (or possibly some weird network thing).

    raise yum.Errors.RepoError, \
RepoError: failed to retrieve repodata/updateinfo.xml.gz from rhel-i386-server-5
error was [Errno -1] Metadata file does not match checksum

...so the updateinfo.xml.gz file doesn't match the checksum it had when the
index was generated.


Comment 3 Donald Holly 2008-07-18 18:26:33 UTC
Do I need to re-generate the index file or does RHEL do this everytime it 
checks for new updates?

Comment 4 Sebastian Skracic 2010-08-26 17:47:06 UTC

*** This bug has been marked as a duplicate of bug 452538 ***


Note You need to log in before you can comment on or make changes to this bug.