Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454435 - traceback installing policy due to indentation error
Summary: traceback installing policy due to indentation error
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: policycoreutils
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 454451 454579 (view as bug list)
Depends On:
Blocks: F10Alpha, F10AlphaBlocker
TreeView+ depends on / blocked
 
Reported: 2008-07-08 14:07 UTC by Jeremy Katz
Modified: 2018-04-11 07:09 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-10 14:08:06 UTC


Attachments (Terms of Use)

Description Jeremy Katz 2008-07-08 14:07:56 UTC
Traceback (most recent call last):
  File "/usr/sbin/semanage", line 24, in <module>
    import seobject
  File "/usr/lib/python2.5/site-packages/seobject.py", line 342
    rc = semanage_commit(self.sh)
                                ^
IndentationError: unindent does not match any outer indentation level

Comment 1 Matěj Cepl 2008-07-08 16:05:43 UTC
*** Bug 454451 has been marked as a duplicate of this bug. ***

Comment 2 Daniel Walsh 2008-07-08 19:10:47 UTC
Fixed in policycoreutils-2.0.52-3

Comment 3 Jeremy Katz 2008-07-09 20:00:43 UTC
Still seeing this with -4

Comment 4 Will Woods 2008-07-09 20:17:41 UTC
For the record, selinux-policy %post runs semanage to set the default user
context, which is why non-root users in current rawhide installs can't see 'su'.

Comment 5 Will Woods 2008-07-10 13:58:22 UTC
*** Bug 454579 has been marked as a duplicate of this bug. ***

Comment 6 Daniel Walsh 2008-07-10 14:08:06 UTC
Try again.

Fixed in policycoreutils-2.0.52-5


Note You need to log in before you can comment on or make changes to this bug.