Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454403 - XML validation errors using fence_rsa
Summary: XML validation errors using fence_rsa
Keywords:
Status: CLOSED DUPLICATE of bug 597253
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: redhat-config-cluster
Version: 4
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ryan McCabe
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-08 10:02 UTC by Laszlo Beres
Modified: 2010-10-25 15:13 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-10-25 15:13:05 UTC


Attachments (Terms of Use)

Description Laszlo Beres 2008-07-08 10:02:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008061712 Fedora/3.0-1.fc9 Firefox/3.0

Description of problem:
If the cluster.conf contains options for the fence-rsa agent, system-config-cluster throws a lot of validation errors.

Version-Release number of selected component (if applicable):
system-config-cluster-1.0.51-2.0.el4_6.2

How reproducible:
Always


Steps to Reproduce:
1. Create cluster.conf with RSA fencing.
2. Append an option:

<fencedevice agent="fence_rsa" ipaddr="el4" login="user" name="rsa" option="reboot" passwd="secret"/>

Actual Results:
Relax-NG validity error : Extra element fencedevices in interleave
/etc/cluster/cluster.conf:14: element fencedevices: Relax-NG validity error : Element cluster failed to validate content
/etc/cluster/cluster.conf fails to validate


Expected Results:


Additional info:

Comment 4 Ryan McCabe 2010-10-25 15:13:05 UTC

*** This bug has been marked as a duplicate of bug 597253 ***


Note You need to log in before you can comment on or make changes to this bug.