Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 454386 - scim is crashing
Summary: scim is crashing
Keywords:
Status: CLOSED DUPLICATE of bug 445129
Alias: None
Product: Fedora
Classification: Fedora
Component: im-chooser
Version: 9
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-08 06:16 UTC by Salil
Modified: 2008-07-14 02:42 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-14 02:42:59 UTC


Attachments (Terms of Use)
output scim start (deleted)
2008-07-08 08:37 UTC, Salil
no flags Details
scim malalayam is installed like this (deleted)
2008-07-08 13:25 UTC, Salil
no flags Details

Description Salil 2008-07-08 06:16:41 UTC
Description of problem:

Hello

I am facing problem in using scim in Fedora -9. I have installed the required
packages but when I start scim, it crashes. The crash report is posted here

http://salilgk.googlepages.com/im-chooser-bugreport.txt

Any pointers on how to fix this

Thanks
Salil

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Peng Huang 2008-07-08 07:18:01 UTC
I can not access http://salilgk.googlepages.com/im-chooser-bugreport.txt. Could
you attach this file on this bug?

Comment 2 Jens Petersen 2008-07-08 07:37:24 UTC
How you updated to the latest im-chooser and imsettings packages from F9 Updates?

Comment 3 Salil 2008-07-08 08:37:09 UTC
Created attachment 311240 [details]
 output scim start

This is what I got output when I tried to start scim component

Comment 4 Salil 2008-07-08 13:25:23 UTC
Created attachment 311263 [details]
scim malalayam is installed like this

Comment 5 Jens Petersen 2008-07-08 23:35:20 UTC
Where do you see that output and how are you starting scim?

Comment 6 Peng Huang 2008-07-08 23:40:32 UTC
(In reply to comment #3)
> Created an attachment (id=311240) [edit]
>  output scim start
> 
> This is what I got output when I tried to start scim component

I only saw error output from im-chooser. Which version of im-chooser do you use?
Did you update im-chooser?

Comment 7 Salil 2008-07-10 17:27:48 UTC
I used gui for starting im-chooser. Then it dumped so I tried to execute
/usr/bin/im-chooser there also it dumped. The following is the output.

>>>>>

[root@Studio ~]# /usr/bin/im-chooser 

(im-chooser:2993): IMSettings-WARNING **: Failed to invoke a method
`WhatInputMethodIsRunning':
  Failed to open file '/tmp/scim_conf:xim::0.0-root': No such file or directory
Segmentation fault

<<<<<

[root@Studio ~]# /usr/bin/im-chooser --version
GNOME im-chooser 0.99.6

Thanks


Comment 8 Peng Huang 2008-07-10 23:02:31 UTC
Please use `rpm -q im-chooser` to check im-chooser's rpm version. If it is early
than 0.99.6-5, please use `yum update im-chooser` to update it.


Comment 9 Peng Huang 2008-07-10 23:04:17 UTC
I thinks it is im-chooser's problem.

Comment 10 Salil 2008-07-11 13:56:28 UTC
Thanks for the advice. I have updated im-chooser and it works. Now could you
please let me know how to learn the keyboard map for Malayalayam itran input
method. Any pointers would be really appreciated.

thanks
Salil 

Comment 11 Akira TAGOH 2008-07-14 02:42:59 UTC
better ask on fedora-i18n-list.

*** This bug has been marked as a duplicate of 445129 ***


Note You need to log in before you can comment on or make changes to this bug.